Project

General

Profile

Feature #78

do_build.sh @ 5673 source code is getting old

Added by Andrei Kolu over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Important
Assignee:
-
Category:
Middleware
Target version:
-
Estimated time:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Description

https://support.freenas.org/browser/freenas/trunk/build/do_build.sh

src-all tag=RELENG_8_1_0_RELEASE
ports-all tag=RELEASE_8_1_0

Update [[FreeBSD]] source code to STABLE or PATCH and ports to current. Ports are enhanced really fast and bugs are fixed- why use old ports from RELEASE?

Suggestion:

src-all tag=RELENG_8_1
ports-all tag=.

History

#1 Updated by Anonymous over 10 years ago

  • Status changed from Unscreened to Closed

This is on purpose. [[FreeNAS]] is based on releases of [[FreeBSD]], plus updates via the patch mechanism. We'll migrate to 8.2 when it is ready, or we'll updates ports as needed. There's already an experimental branch you can use if you desire a more cutting-edge system (see experimental/ix-8.2).

We'll likely use "tag=." because it does not produce reproducible builds. do_build.sh assumes that we have a base, not a constantly evolving system that needs to be cvsup'd each time. do_build.sh would need structural changes to support this efficiently. Experience has shown that having 'whatever is at the tip of ports' or 'whatever is at the tip of src' will produce extremely variable results, lead to difficult to diagnose problems (that likely are fixed) and be more support burden than it is worth.

Also available in: Atom PDF