Project

General

Profile

Bug #7844

USB keyboard not recognized in 9.3 installer

Added by Alexander Strange over 5 years ago. Updated about 3 years ago.

Status:
Closed: User Config Issue
Priority:
Nice to have
Assignee:
Sean Fagan
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I was previously running FreeNAS 9.3 from a USB drive updated from the 9.2 no-installer image.
The drive lost its OS to data corruption, and I tried using the installer image, but can't do anything because it does not respond to keyboard input.
The keyboard works in the BIOS but not afterward.

Workarounds I haven't been able to do:
- Disable "legacy USB" in the BIOS
Can't do this because it disables booting from USB drives, so I'd need some other way to run the installer.
Might work if the installer could boot with UEFI.
- Edit devd.conf
From https://forums.freebsd.org/threads/keyboard-not-working.4166/#post-121230.
Can't do this because I'd need a keyboard to edit it.
- Use a PS/2 keyboard
Haven't tried this yet. A USB->PS/2 adaptor turns out to not work with my keyboard.
- Install 9.2 again and update that
Presumably this will work.

Motherboard: ASUS H87I-PLUS LGA 1150 Intel H87 Mini ITX
CPU: Intel I3-4130T
Keyboard: Apple Extended II + ADB->USB adaptor

History

#1 Updated by Jordan Hubbard over 5 years ago

  • Category set to 1
  • Assignee set to Sean Fagan
  • Target version set to Unspecified

#2 Updated by Sean Fagan over 5 years ago

  • Status changed from Unscreened to Screened

This is a system configuration issue, not an installer issue.

I use a USB keyboard all the time.

#3 Updated by Cyber Jock over 5 years ago

Being that you are using desktop hardware (shame on you), you will probably have to enable or disable some USB keyboard option in the EFI. If that doesn't work I don't know what to say. Had one or two people report this in the forum and couldn't fix it with BIOS settings (always been with desktop hardwae) and the solution was to use proper server hardware.

#4 Updated by Alexander Strange over 5 years ago

Unfortunately I needed it to be silent.

Got the current version back by restoring 9.2 ".img" to the USB media and using the 9.3 upgrade image.
Now that I've done this, the same keyboard works at the text menu! It just doesn't work in the installer.

The same console messages appear when I attach it ("kbd2 at ukbd0").
What would be a way to open an ncurses menu from the shell to see if it works?

#5 Updated by Sean Fagan over 5 years ago

Out of curiosity, do you have any loader.conf / loader.conf.local settings?

#6 Updated by Alexander Strange over 5 years ago

None except those added by autotune.

Well, I bought a different keyboard and it works in the installer environment. That solves the problem for me.
I think debugging the difference between the two keyboards is out of scope for freenas, but it's probably this ADB->USB adaptor which fakes being a usb hub+mouse+keyboard but never actually moves the mouse…

#7 Updated by Jordan Hubbard over 5 years ago

  • Status changed from Screened to Closed: User Config Issue

Thanks, marking this as a user configuration issue then.

#8 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from Unspecified to N/A

Also available in: Atom PDF