Project

General

Profile

Bug #79023

Change install examples to not refer to USB devices

Added by Stephen Makk over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Aaron St. John
Category:
Documentation
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Multiple problems making updates very difficult, and reboots impossible. System runs OK once booted. Trouble seems to be with running OS from USB sticks, but this has worked for years on these systems with earlier revisions.

History

#1 Updated by Stephen Makk over 2 years ago

  • File debug-freenas-20190305230910.txz added
  • Private changed from No to Yes

#2 Updated by Dru Lavigne over 2 years ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Need additional information from Author

Stephen: those symptons are often caused by a failing boot device and this message from the logs almost always indicates that is the case:
sqlite3.OperationalError: database is locked

I see this is a fresh install. What exact model of device are you using for the boot media and what type of slot or port is it plugged into?

#3 Updated by Stephen Makk over 2 years ago

This is a fresh install because previous attempt to update online failed. Using mirrored 32 GB USB flash drives. One installed in internal USB jack and one at rear jack. These are brand new Verbatim "Store N Go" metal flash drives. Product number 98749. Drives were scanned completely on a Windows machine and verified to be legit. I have used similar USB sticks for over a year on earlier versions of FreeNAS OK. I have tried various other USB sticks, but result is same. The ones that were in the machine for previous version were same type and tested OK after replacement. I used new ones, just to be sure.

#4 Updated by Stephen Makk over 2 years ago

I tried reinstalling with various different types of UBS sticks with no better results. I then tried installing two mSATA SSDs mounted to a PCI-e card in the same server. A clean install from DVD went smoothly and the existing ZFS pool on an 8 drive RAID was detected and preserved. All settings were retained and system boots rapidly and cleanly. It appears the issue is with using USB drives for OS in general and seems worse when trying to mirror these drives. I had less trouble with a single drive. Note that these have worked well for many years on same hardware, up to about a year ago. I suggest that FreeNAS stop claiming to support OS on USB flash except for installation. I am using enterprise-grade off the shelf server and good quality USB sticks. I consider this issue closed for my purposes, but hope the information is useful for product improvement.

#5 Updated by Dru Lavigne over 2 years ago

  • File deleted (debug-freenas-20190305230910.txz)

#6 Updated by Dru Lavigne over 2 years ago

  • Status changed from Blocked to Closed
  • Target version changed from Backlog to N/A
  • Private changed from Yes to No
  • Reason for Blocked deleted (Need additional information from Author)

Thanks, Stephen.

#7 Updated by Dru Lavigne over 2 years ago

  • Subject changed from Slow updates, slow boots, loses IP address when rebooted, multiple boot-time errors. Unable to perfrorm online updates. to Change install examples to not refer to USB devices
  • Category changed from OS to Documentation
  • Status changed from Closed to Unscreened
  • Assignee changed from Release Council to Warren Block

#9 Updated by Dru Lavigne over 2 years ago

  • Target version changed from N/A to 11.2-U4

#10 Updated by Warren Block over 2 years ago

  • Assignee changed from Warren Block to Aaron St. John

#12 Updated by Jaron Parsons over 2 years ago

  • Status changed from Unscreened to Closed

Also available in: Atom PDF