Project

General

Profile

Bug #79536

Avatar?id=55038&size=50x50

Fix helptext in Virtual Machines -> Docker VM Wizard of new UI

Added by Zackary Welch over 2 years ago. Updated over 2 years ago.

Status:
Ready for Testing
Priority:
No priority
Assignee:
-
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When typing the Raw file location, before completeing the name of the pool, the following message appears.

${globalHelptext.dockerhost} needs at least 20 GiB.

This appears to be a regression from U2.1, where ${globalHelptext.dockerhost} appeared as 'Docker Container'.


Related issues

Related to FreeNAS - Bug #71013: Improve VM wizard in new UIDone
Has duplicate FreeNAS - Bug #78591: Error message in Docker VM Wizard shows the wrong messageClosed

Associated revisions

Revision 0ab19da2 (diff)
Added by Erin Clark over 2 years ago

Use the proper quotes so globalHelptext variables will work in docker wizard Ticket: #79536

Revision f30d010e (diff)
Added by Erin Clark over 2 years ago

Use the proper quotes so globalHelptext variables will work in docker wizard Ticket: #79536 (cherry picked from commit 0ab19da2b7086b5dfc0d5289cb36c3e888f1e5fb)

History

#1 Avatar?id=55038&size=24x24 Updated by Zackary Welch over 2 years ago

  • Related to Bug #71013: Improve VM wizard in new UI added

#2 Updated by Dru Lavigne over 2 years ago

  • Assignee changed from Release Council to Anonymous
  • Target version changed from Backlog to 11.2-U4

#3 Updated by Anonymous over 2 years ago

  • Status changed from Unscreened to In Progress

Stable PR: https://github.com/freenas/webui/pull/2072
Master PR: https://github.com/freenas/webui/pull/2071 (closed due to removal of docker)

Turns out they just needed the `` quotes instead of '' quotes.

Testing: Docker VM Wizard step 5 (Storage/files) select pool that is smaller than 20 GB should pop up an error message containing "Docker Host" instead of the variable name

#4 Updated by Dennis Mullen over 2 years ago

  • Has duplicate Bug #78591: Error message in Docker VM Wizard shows the wrong message added

#5 Updated by Anonymous over 2 years ago

  • Status changed from In Progress to Ready for Testing
  • Needs Merging changed from Yes to No

#6 Updated by Dru Lavigne over 2 years ago

  • Subject changed from Helptext broken in Virtual Machines -> Docker VM Wizard to Fix helptext in Virtual Machines -> Docker VM Wizard of new UI
  • Needs Doc changed from Yes to No

Also available in: Atom PDF