Project

General

Profile

Bug #79878

Unable to replace disk in GUI, but works in Shell

Added by Genya Kaplun 6 months ago. Updated 5 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Lola Yang
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hello,
There seems to be some sort of problem with re-silvering via GUI, at least when the device wasn't offlined prior to replacement when using GUI.
I had a failed disk, which i was unable to take offline prior to replacing. I replaced it with a new disk. Zpool status showed:

replicator# zpool status
  pool: backups
state: DEGRADED
status: One or more devices has been taken offline by the administrator.
        Sufficient replicas exist for the pool to continue functioning in a
        degraded state.
action: Online the device using 'zpool online' or replace the device with
        'zpool replace'.
  scan: scrub repaired 540K in 0 days 05:28:45 with 0 errors on Wed Mar  6 18:51:22 2019
config:

        NAME                                            STATE     READ WRITE CKSUM
        backups                                         DEGRADED     0     0     0
          raidz3-0                                      DEGRADED     0     0     0
            gptid/a38d9d54-2470-11e7-be70-ac220b8c944c  ONLINE       0     0     0
            gptid/6ba58636-4588-11e7-867f-ac220b8c944c  ONLINE       0     0     0
            gptid/e3acea0a-8574-11e4-9c86-ac220b8c944c  ONLINE       0     0     0
            gptid/18b749b3-c0b6-11e7-81f8-ac220b8c944c  ONLINE       0     0     0
            15678995806359064346                        OFFLINE      0     0     0  was /dev/gptid/8016f0cf-5557-11e4-a84e-ac220b8c944c
            gptid/a0fb3bb7-c685-11e4-acbc-ac220b8c944c  ONLINE       0     0     0
            gptid/80f31598-5557-11e4-a84e-ac220b8c944c  ONLINE       0     0     0
            gptid/8163ab25-5557-11e4-a84e-ac220b8c944c  ONLINE       0     0     0

errors: No known data errors

  pool: freenas-boot
state: ONLINE
  scan: scrub repaired 0 in 0 days 00:01:56 with 0 errors on Sat Mar  2 03:46:56 2019
config:

        NAME        STATE     READ WRITE CKSUM
        freenas-boot  ONLINE       0     0     0
          ada0p2    ONLINE       0     0     0

errors: No known data errors

When I tried to use GUI to replace the disk:

Mar  8 09:58:14 replicator uwsgi: [middleware.exceptions:36] [MiddlewareError: Disk online failed: [EINVAL] options.label: Label /dev/gptid/8016f0cf-5557-11e4-a84e-ac220b8c944c not found on this pool.]
Mar  8 10:00:08 replicator ZFS: vdev state changed, pool_guid=7276832981028910459 vdev_guid=13712933058586299289
Mar  8 10:00:08 replicator ZFS: vdev state changed, pool_guid=7276832981028910459 vdev_guid=4742708301625801581
Mar  8 10:00:08 replicator ZFS: vdev state changed, pool_guid=7276832981028910459 vdev_guid=10722137843091395938
Mar  8 10:00:08 replicator ZFS: vdev state changed, pool_guid=7276832981028910459 vdev_guid=10312215785613305283
Mar  8 10:00:08 replicator ZFS: vdev state changed, pool_guid=7276832981028910459 vdev_guid=15678995806359064346
Mar  8 10:00:08 replicator ZFS: vdev state changed, pool_guid=7276832981028910459 vdev_guid=18414390688458562224
Mar  8 10:00:08 replicator ZFS: vdev state changed, pool_guid=7276832981028910459 vdev_guid=7372792234020972046
Mar  8 10:00:08 replicator ZFS: vdev state changed, pool_guid=7276832981028910459 vdev_guid=14887578890026946931

I also tried to take it offline first, got the same error :
uwsgi: [middleware.exceptions:36] [MiddlewareError: Disk online failed: [EINVAL] options.label: Label /dev/gptid/8016f0cf-5557-11e4-a84e-ac220b8c944c not found on this pool.]

However using shell, I had no problems at all resilvering:
zpool replace backups /dev/gptid/8016f0cf-5557-11e4-a84e-ac220b8c944c /dev/da7
it recognized the old device reference and re-silvered without issues.

Debug attached
OS Version:
FreeNAS-11.3-MASTER-201903071000
(Build Date: Mar 7, 2019 6:15)
Processor:
Intel(R) Xeon(R) CPU E3-1230 v3 @ 3.30GHz (8 cores)
Memory:
16 GiB


Related issues

Is duplicate of FreeNAS - Bug #56454: Convert disk online/offline/replace to WebSocket callReady for Testing

History

#1 Updated by Dru Lavigne 6 months ago

  • Category changed from GUI (new) to Middleware
  • Assignee changed from Release Council to William Grzybowski
  • Private changed from No to Yes
  • Seen in set to Master - FreeNAS Nightlies

#2 Updated by William Grzybowski 6 months ago

  • Category changed from Middleware to GUI (new)
  • Assignee changed from William Grzybowski to Erin Clark
  • Target version changed from Backlog to 11.3-BETA1

#4 Updated by Erin Clark 5 months ago

  • Assignee changed from Erin Clark to Lola Yang

This should be fixed along side 56454

#5 Updated by Erin Clark 5 months ago

  • Related to Bug #56454: Convert disk online/offline/replace to WebSocket call added

#6 Updated by Lola Yang 5 months ago

  • Status changed from Unscreened to In Progress

#7 Updated by Dru Lavigne 5 months ago

  • Related to deleted (Bug #56454: Convert disk online/offline/replace to WebSocket call)

#8 Updated by Dru Lavigne 5 months ago

  • Is duplicate of Bug #56454: Convert disk online/offline/replace to WebSocket call added

#9 Updated by Dru Lavigne 5 months ago

  • File deleted (debug-replicator-20190308154214.tgz)

#10 Updated by Dru Lavigne 5 months ago

  • Status changed from In Progress to Closed
  • Target version changed from 11.3-BETA1 to N/A
  • Private changed from Yes to No
  • Reason for Closing set to Duplicate Issue

Also available in: Atom PDF