Project

General

Profile

Bug #8026

Shadow copies & recursive snapshots Redux again

Added by Masumitsu Hatta over 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
John Hixson
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Running 9.3 release x64 it appears that the requirement for one-to-one mapping between periodic snapshot and CIFS share is back.
CIFS shared datasets that have periodic snapshots from a parent snapshot task set to recursive do not have previous versions available
until a new periodic snapshot task is defined directly on the dataset and samba is restarted.
At that point previous versions become visible.

see #4350


Related issues

Copied from FreeNAS - Bug #4350: Shadow copies & recursive snapshots ReduxClosed2014-02-25

History

#1 Updated by Masumitsu Hatta over 5 years ago

  • Copied from Bug #4350: Shadow copies & recursive snapshots Redux added

#2 Updated by John Hixson over 5 years ago

  • Status changed from Unscreened to Screened
  • Target version set to Unspecified

#3 Updated by John Hixson over 5 years ago

  • Status changed from Screened to 15

Masumitsu Hatta wrote:

Running 9.3 release x64 it appears that the requirement for one-to-one mapping between periodic snapshot and CIFS share is back.
CIFS shared datasets that have periodic snapshots from a parent snapshot task set to recursive do not have previous versions available
until a new periodic snapshot task is defined directly on the dataset and samba is restarted.
At that point previous versions become visible.

So when you pick a snapshot task things work as expected? If so, what is the bug here? Yes, we did change the interface so that you can now pick the particular periodic snapshot you want to use. This makes it more flexible.

see #4350

#4 Updated by Eric Loewenthal over 5 years ago

Works correctly for me. Parent dataset Users has a snapshot task set. Child dataset Eric shows Shadow Copies available (Windows 8.1 x64) for folders inside that dataset.

FreeNAS-9.3-STABLE-201502142001

#5 Updated by Masumitsu Hatta over 5 years ago

1. Parent dataset "tank/svback" has a periodic and recursive snapshot task.
2. Child dataset "tank/svback/server-a" doesn't has a snapshot task (but has snapshots created by parent task).
3. Share "/mnt/tank/svback/server-a" as CIFS share "server-a".

Shadow Copies not available (Windows 2008R2 x64) for share "server-a"
And I can't select snapshot task on CIFS share advanced menu.

Is it correct behavier ?

#6 Updated by John Hixson over 5 years ago

Masumitsu Hatta wrote:

1. Parent dataset "tank/svback" has a periodic and recursive snapshot task.
2. Child dataset "tank/svback/server-a" doesn't has a snapshot task (but has snapshots created by parent task).
3. Share "/mnt/tank/svback/server-a" as CIFS share "server-a".

Shadow Copies not available (Windows 2008R2 x64) for share "server-a"
And I can't select snapshot task on CIFS share advanced menu.

Is it correct behavier ?

I'm looking into this.

#7 Updated by John Hixson over 5 years ago

  • Assignee changed from John Hixson to Josh Paetzel

Masumitsu Hatta wrote:

1. Parent dataset "tank/svback" has a periodic and recursive snapshot task.
2. Child dataset "tank/svback/server-a" doesn't has a snapshot task (but has snapshots created by parent task).
3. Share "/mnt/tank/svback/server-a" as CIFS share "server-a".

Shadow Copies not available (Windows 2008R2 x64) for share "server-a"
And I can't select snapshot task on CIFS share advanced menu.

Is it correct behavier ?

I am able to reproduce this. I'm not clear on if it is correct or not. I have experimented and found all directories beneath a dataset that are not themselves a dataset contain previous versions. If I create a dataset within a dataset with a recursive snapshot, it has previous versions, but it's empty. Is that the same behavior you are seeing? I'm handing this over to Josh to see what he has to say.

#8 Updated by Josh Paetzel over 5 years ago

Can you attach the output of zfs list -t snapshot as well as /usr/local/etc/smb4.conf ?

#9 Updated by Masumitsu Hatta over 5 years ago

  • File smb4.conf added
  • File zfslist.txt added

Thank you for your support and sorry for late.
I attach files.

I set periodic and recursive snapshot task on dataset "tank/svback".
and I'd like to access "tank/svback/fsv-pj01" previous versions.

I think that [fsv-pj01] section on smb4.conf should have for accessing "previous versions"

    shadow:snapdir = .zfs/snapshot
    shadow:sort = desc
    shadow:localtime = yes
    shadow:format = auto-%Y%m%d.%H%M-1w
    vfs objects = recycle shadow_copy2 zfsacl  

#10 Updated by Masumitsu Hatta over 5 years ago

I found that when I add "shadow:snapdirseverywhere = yes"
to [svback] section on smb4.conf then I can access
"previous versions" at anywhere under svback folder !!

So I don't need to create share for every dataset under
tank/svback dataset.

#11 Updated by Josh Paetzel over 5 years ago

commit|744a3ad5dd9cc5769de60b652b0918bbd4fa2e6a

This should be resolved in tonight's nightly.

#12 Updated by Josh Paetzel over 5 years ago

  • Status changed from 15 to Ready For Release
  • Assignee changed from Josh Paetzel to John Hixson

John,
Back over to you and setting as ready to release since the commit got merged.

commit|194502508c810f50a6cfec6943af1440cc56919e

#13 Updated by Jordan Hubbard over 5 years ago

  • Status changed from Ready For Release to Resolved

#14 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from Unspecified to N/A

#15 Updated by Dru Lavigne over 2 years ago

  • File deleted (smb4.conf)

#16 Updated by Dru Lavigne over 2 years ago

  • File deleted (zfslist.txt)

Also available in: Atom PDF