Project

General

Profile

Bug #8149

TFTP service no longer starts on FreeNAS-9.3-STABLE-201502210408

Added by Dave F over 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Expected
Assignee:
Suraj Ravichandran
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When attempting to start the TFTPD service on the latest build, it does not start. The following messages from /var/log/messages:

Feb 22 15:05:41 tardis notifier: tftp does not exist in /etc/rc.d or the local startup
Feb 22 15:05:41 tardis notifier: directories (/etc/ix.rc.d /usr/local/etc/rc.d)
Feb 22 15:05:58 tardis notifier: inetd not running? (check /var/run/inetd.pid).
Feb 22 15:05:58 tardis notifier: Will not 'restart' inetd because inetd_enable is NO.
Feb 22 15:06:01 tardis notifier: tftp does not exist in /etc/rc.d or the local startup
Feb 22 15:06:01 tardis notifier: directories (/etc/ix.rc.d /usr/local/etc/rc.d)
Feb 22 15:06:15 tardis notifier: inetd not running? (check /var/run/inetd.pid).


Related issues

Is duplicate of FreeNAS - Bug #8180: traceback when importing volumeClosed: Duplicate2015-02-24
Is duplicate of FreeNAS - Bug #8181: traceback when click Jails iconClosed: Duplicate2015-02-24
Has duplicate FreeNAS - Bug #8230: Error when detaching zpoolClosed: Duplicate2015-02-26

Associated revisions

Revision 185b868f (diff)
Added by Suraj Ravichandran over 5 years ago

Fix fallout for tftp from recent restart--> normal start/stop regime for services. Some flake8 formattings. Ticket: #8149

Revision ca3adcd7 (diff)
Added by Suraj Ravichandran over 5 years ago

Fix fallout for tftp from recent restart--> normal start/stop regime for services. Some flake8 formattings. Ticket: #8149 (cherry picked from commit 185b868ffac0a00eb35b88bd06d1cf957cb8c823)

Revision efea00c7 (diff)
Added by Suraj Ravichandran over 5 years ago

Fix Broken services world! This one line: "if what in self.__service2daemon:" was there in my head all along justnot in my code! Sorry folks! Ticket: #8149

Revision a08f42ed (diff)
Added by Suraj Ravichandran over 5 years ago

Fix Broken services world! This one line: "if what in self.__service2daemon:" was there in my head all along justnot in my code! Sorry folks! Ticket: #8149 (cherry picked from commit efea00c7a09a63da74507a82d36f084e2146631e)

History

#1 Updated by Josh Paetzel over 5 years ago

  • Category set to 3
  • Assignee set to Suraj Ravichandran
  • Priority changed from Nice to have to Important
  • Target version set to Unspecified

Almost certainly related to 95d4026790275521f657f1f722a25a9d2bd156f8 which William had comments on when it was done which were never addressed.

I can verify the bug report.

#2 Updated by Suraj Ravichandran over 5 years ago

  • Status changed from Unscreened to Screened

@Josh: William did have comments on it....but they were more towards the efficiency of kevent notifications versus outright 1 second sleep intervals.

I discussed this with jordan and also shared the entire me and william email thread with him and his observation on this was that if making a 1 second sleep simplifies our code to a great extent then so be it.

Thus I went ahead with it.

Nontheless, I will look into this soon and get back with a fix or my findings.

#3 Updated by Josh Paetzel over 5 years ago

I believe what happened was this change in services/forms.py:

+ if obj.srv_enable:
+ started = _notifier.start(obj.srv_service)
else:
- started = _notifier.restart(obj.srv_service)
+ started = _notifier.stop(obj.srv_service)

There's no start or stop verbs for tftp in the middleware

Adding the following methods to middleware/notifier.py fixes tftp

def _stop_tftp(self):
self._system("/usr/sbin/service inetd forcestop")
def _start_tftp(self):
self._system("/usr/sbin/service ix-inetd quietstart")
self._system("/usr/sbin/service inetd restart")

#4 Updated by Suraj Ravichandran over 5 years ago

  • Status changed from Screened to Ready For Release

#5 Updated by William Grzybowski over 5 years ago

  • Status changed from Ready For Release to Screened

This is even worse now... this is what I get after trying to create a volume:

Environment:

Software Version: TrueNAS-9.3-Nightlies-201502240447
Request Method: POST
Request URL: http://192.168.3.10/storage/volumemanager/

Traceback:
File "/usr/local/lib/python2.7/site-packages/django/core/handlers/base.py" in get_response
  105.                     response = middleware_method(request, callback, callback_args, callback_kwargs)
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/middleware.py" in process_view
  157.         return login_required(view_func)(request, *view_args, **view_kwargs)
File "/usr/local/lib/python2.7/site-packages/django/contrib/auth/decorators.py" in _wrapped_view
  22.                 return view_func(request, *args, **kwargs)
File "/usr/local/www/freenasUI/../freenasUI/storage/views.py" in volumemanager
  146.         if form.is_valid() and form.save():
File "/usr/local/www/freenasUI/../freenasUI/storage/forms.py" in save
  296.         notifier().start("ix-syslogd")
File "/usr/local/www/freenasUI/../freenasUI/middleware/notifier.py" in start
  325.         self._simplecmd("start", what)
File "/usr/local/www/freenasUI/../freenasUI/middleware/notifier.py" in _simplecmd
  216.             procname, pidfile = self.__service2daemon[what]

Exception Type: KeyError at /storage/volumemanager/
Exception Value: 'ix-syslogd'

#6 Updated by William Grzybowski over 5 years ago

  • Priority changed from Important to Expected

#7 Updated by William Grzybowski over 5 years ago

  • Is duplicate of Bug #8180: traceback when importing volume added

#8 Updated by William Grzybowski over 5 years ago

  • Is duplicate of Bug #8181: traceback when click Jails icon added

#9 Updated by Suraj Ravichandran over 5 years ago

  • Status changed from Screened to Ready For Release

#10 Updated by Jordan Hubbard over 5 years ago

  • Status changed from Ready For Release to Resolved

#11 Updated by Jordan Hubbard over 5 years ago

  • Has duplicate Bug #8230: Error when detaching zpool added

#12 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from Unspecified to N/A

Also available in: Atom PDF