Project

General

Profile

Bug #8195

update notification with multiple times the same updates

Added by Thomas Stather over 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
Jordan Hubbard
Category:
-
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hi

I'm on FreeNAS-9.3-STABLE-201502110455 and i noticed that when i click on update i get a list of updates.
But the updates are displayed multiple times. In addition, the mail i get about the update notification contains the multiple updates as well.

Best,
Thomas

FreeNAS.jpg (214 KB) FreeNAS.jpg Thomas Stather, 02/26/2015 05:28 AM
2251

History

#1 Updated by William Grzybowski over 5 years ago

Got an example?

#2 Updated by William Grzybowski over 5 years ago

  • Assignee set to Sean Fagan
  • Target version set to Unspecified

Actually I have seen this before. Pretty sure the bug is in parse_changelog (freenasUI.system.utils) that Sean wrote a while ago.

#3 Updated by Sean Fagan over 5 years ago

  • Status changed from Unscreened to 15

Screenshot or any other information would be useful.

#4 Updated by Thomas Stather over 5 years ago

2251

Heres a screenshot, sorry i forgot to upload it

#5 Updated by Sean Fagan over 5 years ago

This is actually in the changelog itself:

  1. START FreeNAS-9.3-STABLE-201502142001
    #7675 Bug Normal upsmon.conf and rc.shutdown missing functionality to actually shutoff the UPS
    #7775 Bug Normal Can't get NFSv4/kerberos to work
    #7881 Feature Normal Annotate Vmware Sync Snapshot
    #7882 Feature Normal Add option to restart WebDAV when unlocking encrypted pool
    #7884 Bug Urgent Update failed error
  1. END FreeNAS-9.3-STABLE-201502142001
  2. START FreeNAS-9.3-STABLE-201502162250
    #7675 Bug Normal upsmon.conf and rc.shutdown missing functionality to actually shutoff the UPS
    #7775 Bug Normal Can't get NFSv4/kerberos to work
    #7881 Feature Normal Annotate Vmware Sync Snapshot
    #7882 Feature Normal Add option to restart WebDAV when unlocking encrypted pool
    #7884 Bug Urgent Update failed error
  1. END FreeNAS-9.3-STABLE-201502162250

So that part is Behaves Corrrectly.

I think the problem is that the Feb 14th update was a bit botched. Or the changelog for the 16th was botched.

The solution is to edit the file, which I will do later.

#6 Updated by Thomas Stather over 5 years ago

OK i applied the last update, lets see if the error went away.

#7 Updated by Sean Fagan over 5 years ago

  • Status changed from 15 to Fix In Progress
  • Assignee changed from Sean Fagan to Jordan Hubbard

I removed the ones for the 20150214 update.

Jordan, anything you want to think about this ere I close it?

#8 Updated by Jordan Hubbard over 5 years ago

Nope, I'd say this is closable given the hand-editing you did to eliminate the bogus 0214 update. Thanks!

#9 Updated by Jordan Hubbard over 5 years ago

  • Status changed from Fix In Progress to Ready For Release

#10 Updated by Jordan Hubbard over 5 years ago

  • Status changed from Ready For Release to Resolved

#11 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from Unspecified to N/A

Also available in: Atom PDF