Project

General

Profile

Bug #8203

Smartd failed to start, but shows as "on" in WebGUI

Added by Cyber Jock over 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Important
Assignee:
Erin Clark
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

After upgrading to FreeNAS-9.3-STABLE-201502232343 the following is shown in the footer:

Feb 25 20:18:06 dev-nas-01 smartd4073: Unable to register SCSI device /dev/da12 at line 4 of file /usr/local/etc/smartd.conf
Feb 25 20:18:06 dev-nas-01 smartd4073: Unable to register device /dev/da12 (no Directive -d removable). Exiting.
Feb 25 20:18:06 dev-nas-01 root: /etc/rc: WARNING: failed to start smartd

The WebGUI showed SMART was "ON". So I stopped it.

Feb 25 20:21:25 dev-nas-01 notifier: Will not 'stop' smartd because smartd_enable is NO.

Then I tried to start it again.

Feb 25 20:21:27 dev-nas-01 notifier: Starting smartd.
Feb 25 20:21:27 dev-nas-01 smartd5792: Unable to register SCSI device /dev/da12 at line 4 of file /usr/local/etc/smartd.conf
Feb 25 20:21:27 dev-nas-01 smartd5792: Unable to register device /dev/da12 (no Directive -d removable). Exiting.
Feb 25 20:21:27 dev-nas-01 root: /usr/local/etc/rc.d/smartd: WARNING: failed to start smartd

Now the SMART switch stays in "OFF"

Debug is attached in case it is desired.

History

#1 Updated by Jordan Hubbard over 5 years ago

  • Category set to 55
  • Assignee set to Josh Paetzel
  • Target version set to Unspecified

#2 Updated by Cyber Jock over 5 years ago

  • Assignee deleted (Josh Paetzel)

OOps, screwed up where I should have said I restarted it, but I think you'll get my point.

#3 Updated by Jordan Hubbard over 5 years ago

  • Assignee set to Josh Paetzel

#4 Updated by Josh Paetzel over 5 years ago

  • Status changed from Unscreened to Screened
  • Priority changed from Nice to have to No priority

We need to refactor the smart stuff for sure, I already have a plan for this but currently it is buried as a low priority item.

#5 Updated by Jordan Hubbard over 5 years ago

  • Target version changed from Unspecified to 136

I think we should save the refactor for 10. At some point, we have to simply declare what we have in 9.3 good enough and just fix bugs but resist the temptation to hack on the infrastructure or we'll never switch over to working on the new hotness.

#6 Updated by Josh Paetzel over 5 years ago

  • Status changed from Screened to Unscreened
  • Assignee changed from Josh Paetzel to Jordan Hubbard
  • Seen in changed from to 9.3-RELEASE

This is related to the bug erin is working on.

#7 Updated by Jordan Hubbard over 5 years ago

  • Assignee changed from Jordan Hubbard to Erin Clark
  • Priority changed from No priority to Important
  • Target version changed from 136 to Unspecified

#8 Updated by Jordan Hubbard over 5 years ago

This may already be fixed by your changes, but worth reviewing to be sure.

#9 Updated by William Grzybowski over 5 years ago

This is a design problem of the services management in 9.x that exists since day 1 (8.x). The bits are overloaded and there is no status to indicate "this service is enabled by the user" vs "this service is not running right now".

I suggest this to be moved to 10.

#10 Updated by Erin Clark over 5 years ago

  • Status changed from Unscreened to Screened

#11 Updated by Erin Clark over 5 years ago

  • Status changed from Screened to Fix In Progress

fa93c7113aa29ac0b398a4fdb8540cd9c4976951 should fix most issues where a drive is set to have smart on but is not enabled once it makes it to a SU, I had Cyberjock test last night's nightly which has that commit and he confirmed it working

#12 Updated by Erin Clark over 5 years ago

  • Status changed from Fix In Progress to Resolved

The commit that fixes this has been released

#13 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from Unspecified to N/A

#14 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug-dev-nas-01-20150225202631.tgz)

Also available in: Atom PDF