Project

General

Profile

Bug #8286

Upgrade failure

Added by Bill Pye over 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
William Grzybowski
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

The recent update appears to have failed with the following message:

"CRITICAL: Update failed. Check /data/update.failed for further details."

I've attached the logfile that was produced, if there's any further infor required just let me know.


Related issues

Related to FreeNAS - Bug #8299: CRITICAL: Update failed.Closed: Duplicate2015-03-01
Has duplicate FreeNAS - Bug #8290: services tab trows error after update to FreeNAS-9.3-STABLE-201502271818Closed: Duplicate2015-02-28
Is duplicate of FreeNAS - Bug #8366: update to STABLE-201502271818 fails with services:0160_pwencrypt errorClosed: Duplicate2015-03-04

Associated revisions

Revision 8140dcc1 (diff)
Added by William Grzybowski over 5 years ago

Workaround stupid bug in sqlite3/django/south Ticket: #8286

Revision 85f319d2 (diff)
Added by William Grzybowski over 5 years ago

Workaround stupid bug in sqlite3/django/south Ticket: #8286 (cherry picked from commit 8140dcc1c17cbab462fb8d8dfbbd026fb27e3e40)

Revision 79e01197 (diff)
Added by William Grzybowski over 5 years ago

Workaround stupid bug in sqlite3/django/south Ticket: #8286 (cherry picked from commit 8140dcc1c17cbab462fb8d8dfbbd026fb27e3e40)

History

#1 Updated by William Grzybowski over 5 years ago

You have not attached anything.

#2 Updated by Bill Pye over 5 years ago

  • File 2015-02-28 - FreeNAS failed update log added

Perhaps that's another bug, I did attach the logfile and sent this report via the server Admin UI. :) Hopefully it should now be attached to this report.

#3 Updated by Daniel O'Leary over 5 years ago

I have the exact same issue, with exact same log content.

#4 Updated by Sean Fagan over 5 years ago

  • Category set to 1
  • Assignee set to William Grzybowski
  • Target version set to Unspecified

Tentatively sending to William.

#5 Updated by Jordan Hubbard over 5 years ago

  • Has duplicate Bug #8290: services tab trows error after update to FreeNAS-9.3-STABLE-201502271818 added

#6 Updated by Jordan Hubbard over 5 years ago

  • Related to Bug #8299: CRITICAL: Update failed. added

#7 Updated by Alfred Schlütter over 5 years ago

TEMP-FIX:

In field dc_kerberos_realm_id in table services_domaincontroller must be an integer.

I did change this from NONE to 1 in my freenas-backup.db and upload my backup successfully.

I edit the sqlite db with: http://sqlitebrowser.org/

#8 Updated by William Grzybowski over 5 years ago

  • Status changed from Unscreened to Screened

#9 Updated by William Grzybowski over 5 years ago

Can anyone email me the database prior to upgrade?

Thank you.

#10 Updated by Bill Pye over 5 years ago

I have a config backup from 13th Feb, is the database in there? Note that I have also applied the previous updates to the system prior to this recent failure. If that backup is of any use let me know and I'll send it.

#11 Updated by William Grzybowski over 5 years ago

Yes it is.

#12 Updated by William Grzybowski over 5 years ago

  • Status changed from Screened to Ready For Release

#13 Updated by William Grzybowski over 5 years ago

  • Is duplicate of Bug #8366: update to STABLE-201502271818 fails with services:0160_pwencrypt error added

#14 Updated by Jordan Hubbard over 5 years ago

  • Status changed from Ready For Release to Resolved

#15 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from Unspecified to N/A

#16 Updated by Dru Lavigne almost 3 years ago

  • File deleted (2015-02-28 - FreeNAS failed update log)

Also available in: Atom PDF