Project

General

Profile

Bug #82987

Add tunable to ignore NO_VGA in buggy ACPI firmware

Added by Alan Coe over 2 years ago. Updated over 2 years ago.

Status:
Ready for Testing
Priority:
No priority
Assignee:
Ryan Moeller
Category:
OS
Target version:
Seen in:
Severity:
Low Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Trying to upgrade to 11.2 for 11.1.6 and when I try through the GUI, I get errors about unable to MOUNT BOOT/Grub (See attached picture).

I have also tried to install manually, first with an ISO on a USB and the second attempt was made with a CD. I removed the original USB to eliminate that as a potential issue. I can get both to boot and launch the install, but they both hang on the blue "BOOTING..." message and do not advance.

The system board is an ASROCK Q2900 with 16GB RAM.

20190319_185052.jpg (735 KB) 20190319_185052.jpg Alan Coe, 03/20/2019 10:48 AM
62019

History

#1 Updated by Alan Coe over 2 years ago

  • File debug-freenas-20190320174848.txz added
  • Private changed from No to Yes

#2 Updated by Alan Coe over 2 years ago

62019

#3 Updated by Sean Fagan over 2 years ago

There's not enough information here for me to figure out what's going on; the error generally means that /boot/grub is already mounted somewhere else, or that there's no entry for it in /etc/fstab. The latter happens if one has ever upgraded to 11.2, but based on the set of boot environments on the system, that doesn't appear to be the case here. Hm.

Looking at fndebug/Grub/dump.txt, there is no content in /boot/grub/grub.cfg. This could be because it's empty (which would certainly ensure booting doesn't work), or because /boot/grub isn't there.

Can you please show the output of "mount -v"?

#5 Updated by Dru Lavigne over 2 years ago

  • Category changed from Middleware to OS
  • Assignee changed from Release Council to Sean Fagan

#6 Updated by Sean Fagan over 2 years ago

Well, there you go, /boot/grub isn't mounted. But the update code expects it to be.

Is /boot/grub listed in /etc/fstab?

#7 Updated by Alan Coe over 2 years ago

Sean Fagan wrote:

Well, there you go, /boot/grub isn't mounted. But the update code expects it to be.

Is /boot/grub listed in /etc/fstab?

No,
Here is the content of the file (2 lines)

fdescfs /dev/fd fdescfs rw      0 0                                                                                                 
/dev/mirror/swap0.eli none swap sw 0 0

#8 Updated by Sean Fagan over 2 years ago

Ok. So that's the problem. I can tell you how to work around that issue, but I'm not sure if that'll do anything about the ability to boot afterwards.

To deal with the fstab problem, do:

echo "freenas-boot/grub    /boot/grub    zfs    rw,noatime    1    0" >> /conf/base/etc/fstab
shutdown -r now

Since I don't know how your system got into this state, I'm not sure what else might happen, however.

#9 Updated by Alan Coe over 2 years ago

ok, that fixed the upgrade issue, and it completed without errors. However, when I rebooted the system, and choose the 11.2 boot environment, it hangs at the BOOTING... prompt. The same thing happens if I try and boot with the install CD (ISO) or USB ISO. I can choose the 11.1.6 boot environment and it works every time. I am wondering if there is some sort of system compatibility issue. I have the latest firmware on the ASROCK board (Q2900). The only peripherals I have are the onboard NIC, and the keyboard/mouse. (and 2 WD 3 TB Drives)

#10 Updated by Sean Fagan over 2 years ago

  • Assignee changed from Sean Fagan to Ryan Moeller

The 11.2 upgrade replaces the boot loader, which makes things complicated. It should have booted once, done stuff, and then booted again -- but at that point, it's under the new boot loader. (Also, as part of the upgrade process, it changes the fstab files. So as I think about it, that's undoubtedly how you got into this situation.)

Ryan, any ideas here?

#11 Updated by Alan Coe over 2 years ago

I saw some threads with a similar issue related to the ASROCK J1900 and BSD 11.2. Maybe its the same issue? Even a clean iso with the Freenas 11.2 won't get past the BOOTING... prompt. Unfortunately I didn't see any definitive resolutions to the J1900 issue.

#12 Updated by Ryan Moeller over 2 years ago

Here is the relevant issue in FreeBSD's bug tracker: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=230172

It's a hot ticket. The issue seems to be the switch from sc to vt as the system video console driver, rather than the boot loader.

The hw.vga.acpi_ignore_no_vga=1 workaround suggested on bugzilla will not work on the released versions of FreeNAS 11.2 but that change is in our 11-stable branch for 11.3. I will see if we can merge it in for 11.2-U4 though and possibly set that by default.

I believe there are a few other hardware platforms with a similar issue in firmware, but I'm not aware of the consequences of that setting when there is actually no VGA hardware or how common that hardware is with FreeNAS users.

#13 Updated by Ryan Moeller over 2 years ago

  • Status changed from Unscreened to Blocked
  • Severity changed from New to Low Medium
  • Reason for Blocked set to Need additional information from Author

Alan: Please try booting an 11.3 snapshot and confirm you have the same issue, then try the workaround and let us know if it solves your problem.

A snapshot ISO can be downloaded here: https://download.freenas.org/11.3/MASTER/latest/x64/

To apply the workaround, first interrupt the boot loader by pressing 3 to view the options menu then 6 to escape to a loader prompt. At the prompt try the following commands:

set hw.vga.acpi_ignore_no_vga=1 
boot

If you get stuck still, it would be helpful to get a screenshot.

#14 Updated by Alan Coe over 2 years ago

Ok, so I booted the 11.3 snapshot from yesterday, and confirmed I had the same issue. I tried again with the workaround and it worked. I got to the point of upgrading my USB drive and I stopped as I didn't want to mess with my current config. I found a spare drive and tested again, hung without the workaround, but when the workaround was applied, I was able to do a full fresh install of 11.3 with no issues.

I tried the workaround in 11.2 and as you said it doesn't work.

So at this point, I suppose I should stay on 11.1.6 until either 11.2-u4 (if it includes the fix) or wait for 11.3?

#15 Updated by Ryan Moeller over 2 years ago

  • Status changed from Blocked to In Progress
  • Target version changed from Backlog to 11.2-U4
  • Reason for Blocked deleted (Need additional information from Author)

Excellent, thanks for testing that out.

You are correct, staying on 11.1 until at least 11.2-U4 is what I recommend.

#16 Updated by Ryan Moeller over 2 years ago

  • Subject changed from Upgrade from 11.1.6 to 11.2 fails to Add tunable to ignore NO_VGA in buggy ACPI firmware

#17 Updated by Ryan Moeller over 2 years ago

  • Status changed from In Progress to Ready for Testing
  • Needs Merging changed from Yes to No

#19 Updated by Dru Lavigne over 2 years ago

  • File deleted (debug-freenas-20190320174848.txz)

#20 Updated by Dru Lavigne over 2 years ago

  • Private changed from Yes to No

Also available in: Atom PDF