Project

General

Profile

Bug #83035

Samba Home share in AD environment

Added by Alexander Mladenov 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Andrew Walker
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Home shares stopped working after 11.2 update, other shares are working with the same user credentials, when trying to access the user's home share I get access denied, checked the samba logs:
[2019/03/20 19:42:59.019181, 1] ../source3/smbd/service.c:357(create_connection_session_info)
create_connection_session_info: user 'WWR\admin' (from session setup) not permitted to access this share (admin)
[2019/03/20 19:42:59.019234, 1] ../source3/smbd/service.c:529(make_connection_snum)
create_connection_session_info failed: NT_STATUS_ACCESS_DENIED


Related issues

Is duplicate of FreeNAS - Bug #75883: Fix "valid users" parameter for [homes] in Samba 4.9Done

History

#1 Updated by Alexander Mladenov 5 months ago

  • File debug-freenas-20190320185510.txz added
  • Private changed from No to Yes

#2 Updated by Dru Lavigne 5 months ago

  • Assignee changed from Release Council to William Grzybowski

#3 Updated by William Grzybowski 5 months ago

  • Assignee changed from William Grzybowski to Andrew Nguyen
  • Target version changed from Backlog to 11.2-U4

#4 Updated by Dru Lavigne 5 months ago

  • Assignee changed from Andrew Nguyen to Andrew Walker

#5 Updated by Andrew Walker 5 months ago

[homes]
    valid users = %D\%U
    path = "/mnt/raid0/home/%D/%U" 
    comment = Home Directories
    printable = no
    veto files = /.snapshot/.windows/.mac/.zfs/
    writeable = yes
    browseable = yes
    access based share enum = no
    vfs objects = acl_xattr acl_tdb zfs_space zfsacl streams_xattr
    hide dot files = yes
    guest ok = no
    nfs4:mode = special
    nfs4:acedup = merge
    nfs4:chown = true
    zfsacl:acesort = dontcare

remove acl_xattr and acl_tdb. Those should not be set on FreeNAS.

This is a regression I fixed in the upcoming U3 release. Try setting the following auxiliary parameter under your ['homes'] SMB share:

valid_users = "%U"

#6 Updated by Alexander Mladenov 5 months ago

Andrew Walker wrote:

[...]
remove acl_xattr and acl_tdb. Those should not be set on FreeNAS.

This is a regression I fixed in the upcoming U3 release. Try setting the following auxiliary parameter under your ['homes'] SMB share:
[...]

Thank you so much, I managed to fix this adding auxiliary option "valid users ="

#7 Updated by Andrew Walker 5 months ago

  • Reason for Closing set to Duplicate Issue
  • Needs QA changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

Alexander Mladenov wrote:

Andrew Walker wrote:

[...]
remove acl_xattr and acl_tdb. Those should not be set on FreeNAS.

This is a regression I fixed in the upcoming U3 release. Try setting the following auxiliary parameter under your ['homes'] SMB share:
[...]

Thank you so much, I managed to fix this adding auxiliary option "valid users ="

Of course, that works as well (in 11.3 we're not setting a 'valid users' string for [homes]). I'll go ahead and close out this ticket.

#8 Updated by Dru Lavigne 5 months ago

  • Is duplicate of Bug #75883: Fix "valid users" parameter for [homes] in Samba 4.9 added

#9 Updated by Dru Lavigne 5 months ago

  • File deleted (debug-freenas-20190320185510.txz)

#10 Updated by Dru Lavigne 5 months ago

  • Target version changed from 11.2-U4 to N/A
  • Private changed from Yes to No

#11 Updated by Andrew Walker 5 months ago

  • Status changed from Unscreened to Closed
  • Target version changed from N/A to 11.2-U4

#12 Updated by Dru Lavigne 5 months ago

  • Target version changed from 11.2-U4 to N/A

Also available in: Atom PDF