Project

General

Profile

Bug #8304

collectd: write_graphiteplugin: send to localhost failed with -1 (Broken pipe)

Added by Václav Navrátil over 6 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
No priority
Assignee:
Jakub Klama
Category:
Middleware
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

This is a persistent error on a VM console after my laptop returned from a sleep mode. This problem might be limited only to this specific situation.

version.png (15.7 KB) version.png Václav Navrátil, 03/02/2015 01:00 AM
error.png (80.3 KB) error.png Václav Navrátil, 03/02/2015 01:00 AM
2287
2288

Associated revisions

Revision a2bb89e6 (diff)
Added by Jakub Klama over 6 years ago

Restart fnstatd when dispacher closes middleware connection. Let's see if this helps. Ticket: #8304

Revision 74ced78d (diff)
Added by Jakub Klama over 6 years ago

Restart fnstatd when dispacher closes middleware connection. Let's see if this helps. Ticket: #8304

Revision 46f80843 (diff)
Added by Jakub Klama over 6 years ago

Fix incorrectly created server thread. Ticket: #8304

Revision adc6b552 (diff)
Added by Jakub Klama over 6 years ago

Fix incorrectly created server thread. Ticket: #8304

History

#1 Updated by Jakub Klama over 6 years ago

  • Status changed from Unscreened to Screened

Could you attach contents of /var/log/fnstatd.log file?

#2 Updated by Václav Navrátil over 6 years ago

  • File fnstatd.log added

Here it is. It keeps happening even in the newer version.

#3 Updated by Jakub Klama over 6 years ago

  • Status changed from Screened to Investigation

Can you prepare exact instructions how to reproduce it? So far I have no luck trying to reproduce it locally.

#4 Updated by Václav Navrátil over 6 years ago

I believe that it is connected with the time you spend on dashboard. Leave dashboard in an active tab in your browser overnight. I didn't seen this problem lately. I will also try to reproduce it.

#5 Updated by Václav Navrátil over 6 years ago

I'm not able to reproduce this problem. It might be connected with incorrect unsubscription of dashboard widgets.

#6 Updated by Václav Navrátil over 6 years ago

I updated and restarted the machine yesterday evening. Today I start working on it for and hour (grunt & reloading of the dashboard) then I get back to the code for a while (20 min) and Chrome tab with dashboard died and after first reload I get error:

wiredData: Traceback (most recent call last): File "/usr/local/lib/python2.7/site-packages/dispatcher/rpc.py", line 130, in dispatch_call result = func(*args)
File "/usr/local/lib/dispatcher/src/services.py", line 105, in call_wrapped *args)
File "/usr/local/lib/dispatcher/src/main.py", line 781, in call_client_sync event = self.call_client(method, None, *args)
File "/usr/local/lib/dispatcher/src/main.py", line 764, in call_client self.emit_rpc_call(id, method, args)
File "/usr/local/lib/dispatcher/src/main.py", line 810, in emit_rpc_call return self.send_json(payload)
File "/usr/local/lib/dispatcher/src/main.py", line 837, in send_json self.ws.send(data)
File "/usr/local/lib/python2.7/site-packages/geventwebsocket/websocket.py", line 348, in send raise WebSocketError(MSG_SOCKET_DEAD) WebSocketError: Socket is dead

#7 Updated by Jakub Klama over 6 years ago

  • Status changed from Investigation to 15

Let's see if a2bb89e6 will fix it.

#8 Updated by Jakub Klama over 6 years ago

  • Status changed from 15 to Resolved

Finally fixed.

#9 Updated by Dru Lavigne almost 4 years ago

  • Target version set to Master - FreeNAS Nightlies

#10 Updated by Dru Lavigne almost 4 years ago

  • File deleted (fnstatd.log)

Also available in: Atom PDF