Project

General

Profile

Bug #83067

Fix "smartd not running" alert

Added by Bonnie Follweiler over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Vladimir Vinogradenko
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

This is seen in FreeNAS 11.2-U3 Pre-Release
Because there is a delay in which the smartd process starts, an email alert is generated and sent to the customer.
Eventually the smartd process starts and the the alert is removed from the GUI.

My suggestion is to fix this so an email isn't sent to avoid unnecessary reports/complaints

SMART.png (25.9 KB) SMART.png Jeff Ervin, 03/26/2019 11:18 AM
SMART2.png (42.1 KB) SMART2.png Jeff Ervin, 03/26/2019 11:19 AM
62684
62692

Related issues

Copied to FreeNAS - Bug #83475: The system is sending an email "smartd_daemon is not running" because t There is a delay in which the smartd process startsDone

History

#1 Updated by William Grzybowski over 2 years ago

  • Assignee changed from William Grzybowski to Vladimir Vinogradenko
  • Target version changed from Backlog to 11.2-U4

#2 Updated by Dru Lavigne over 2 years ago

  • Target version changed from 11.2-U4 to 11.2-U3

#4 Updated by Bug Clerk over 2 years ago

  • Status changed from Unscreened to In Progress

#5 Updated by Vladimir Vinogradenko over 2 years ago

Acceptance Criteria

I imagine this happens on huge systems and you can repeat this by just restarting smart daemon — in a minute e-mail will come. This should not be happening anymore.

However, if you stop smart service, alert should still appear.

#6 Updated by Bug Clerk over 2 years ago

  • Status changed from In Progress to Ready for Testing

#7 Updated by Bug Clerk over 2 years ago

  • Copied to Bug #83475: The system is sending an email "smartd_daemon is not running" because t There is a delay in which the smartd process starts added

#9 Updated by Dru Lavigne over 2 years ago

  • Subject changed from The system is sending an email "smartd_daemon is not running" because t There is a delay in which the smartd process starts to Fix "smartd not running" alert
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#10 Updated by Bonnie Follweiler over 2 years ago

On reboot fn01.lab.ixsystems.com running FreeNAS-11.2-U3-INTERNAL1 I get the email

2:14 PM (2 minutes ago)
to me
FreeNAS @ fn01.tn.ixsystems.com

Gone alerts:
  • smartd is not running

#11 Updated by Jeff Ervin over 2 years ago

62684
62692

The attached screenshot shows the settings for S.M.A.R.T.

#12 Updated by Bonnie Follweiler over 2 years ago

  • Status changed from Ready for Testing to Failed Testing

#14 Updated by Bonnie Follweiler over 2 years ago

I set up critical to 20 to force an alert
I rebooted and got:

8:54 AM (2 minutes ago)
to me
FreeNAS @ freenas.local

New alerts:
  • smartd is not running
Current alerts:
  • There is a new update available! Apply it in System -> Update tab.
  • smartd is not running

Smartd should be running and it shouldn't have sent that error message.

I also got emailed the correct Alert message, because of the testing, "Device: /dev/da36, Temperature 46 Celsius reached critical limit of 20 Celsius (Min/Max ??/46)"

I set the critical back to 0 (default) and manually cleared the alerts I don't get the smartd message on reboot

#16 Updated by Dru Lavigne over 2 years ago

  • Status changed from Failed Testing to In Progress
  • Target version changed from 11.2-U3 to 11.2-U4

#18 Updated by Jaron Parsons over 2 years ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF