Project

General

Profile

Bug #8309

W:DYNDNS: Failed updating alias table...

Added by Mig Ponce over 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
Erin Clark
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I keep see this messages: Failed updating alias table...

Skipping IP update attempt subsequent to fatal dyndns server update error for alias, freenaslocal.ignorelist.com.
This client should be stopped and corrected for configuration errors, and restarted... **************************************************************
Mar 2 13:12:19 freenas INADYN2854: Mon Mar 2 13:12:19 2015: W:'RC_ERROR' (0x1) updating the IPs. (it 0)
Mar 2 13:12:19 freenas INADYN2854: Mon Mar 2 13:12:19 2015: W:INADYN: IP address for alias 'freenaslocal.ignorelist.com:auto' needs update to 'xx.xx.xxx.'...
Mar 2 13:12:19 freenas INADYN2854: Mon Mar 2 13:12:19 2015: E:INADYN:

but if i update the ip to xx.xx.xxx.xx in my afraid.org account i redirect to my router login page

i attach my var logs

freenas.jpg (36.9 KB) freenas.jpg Mig Ponce, 03/05/2015 08:12 PM
2346

Associated revisions

Revision 6da18a89 (diff)
Added by Erin Clark over 5 years ago

Change filename of 0165_fix_ddns_domains_delimiters.py to the next number in sequence Ticket: #8309 Merge-FN93:Yes Merge-TN93:Yes

Revision 070dd19b (diff)
Added by Erin Clark over 5 years ago

Change filename of 0165_fix_ddns_domains_delimiters.py to the next number in sequence Ticket: #8309 Merge-FN93:Yes Merge-TN93:Yes (cherry picked from commit 6da18a897c511cbdf59fdd1a0ced7678dd4300fa)

Revision 534521a5 (diff)
Added by Erin Clark over 5 years ago

Change filename of 0165_fix_ddns_domains_delimiters.py to the next number in sequence Ticket: #8309 Merge-FN93:Yes Merge-TN93:Yes (cherry picked from commit 6da18a897c511cbdf59fdd1a0ced7678dd4300fa)

History

#1 Updated by Mig Ponce over 5 years ago

2346

!!!!Mig Ponce wrote:

I keep see this messages: Failed updating alias table...

Skipping IP update attempt subsequent to fatal dyndns server update error for alias, freenaslocal.ignorelist.com.
This client should be stopped and corrected for configuration errors, and restarted... **************************************************************
Mar 2 13:12:19 freenas INADYN2854: Mon Mar 2 13:12:19 2015: W:'RC_ERROR' (0x1) updating the IPs. (it 0)
Mar 2 13:12:19 freenas INADYN2854: Mon Mar 2 13:12:19 2015: W:INADYN: IP address for alias 'freenaslocal.ignorelist.com:auto' needs update to 'xx.xx.xxx.'...
Mar 2 13:12:19 freenas INADYN2854: Mon Mar 2 13:12:19 2015: E:INADYN:

but if i update the ip to xx.xx.xxx.xx in my afraid.org account i redirect to my router login page

i attach my var logs

Here is my dns configuration (image attachment)

#2 Updated by Jordan Hubbard over 5 years ago

  • Category set to 36
  • Assignee set to Erin Clark
  • Seen in changed from to

I think this is a duplicate; does this look familiar, Erin?

#3 Updated by Erin Clark over 5 years ago

  • Status changed from Unscreened to Screened

#4 Updated by Björn Voigt over 5 years ago

I can confirm this bug.

Work-around: Until it's fixed, I use a cronjob (created from GUI) to update my afraid.org dynamic DNS hosts. An example cronjob can be found at afraid.org (replace wget with /usr/local/bin/wget).

#5 Updated by Björn Voigt over 5 years ago

After some investigations I found, that the problem is mainly caused by start/stop script /etc/ix.rc.d/ix-inadyn.

The function generate_inadyn_real() takes the dynamic DNS domain from SQLite table services_dynamicdns.

select ddns_domain from services_dynamicdns;
mynas.ignorelist.com,Miwiwhh-the-hash-value

The problem is, that the function generate_inadyn_real() splits this value into two DNS aliases (here: --alias mynas.ignorelist.com --alias Miwiwhh-the-hash-value). Normally for other dynamic DNS services this is OK. But afraid.org DNS service' implementation in inadyn-mt needs the hash together with the alias (--alias mynas.ignorelist.com,Miwiwhh-the-hash-value). The start/stop script should respect this exception.

An related problem is, that I FreeNAS GUI (Dynamic DNS service) it's unclear, that the correct entry for "Domain name:" is the host alias AND the hash value.

#6 Updated by Erin Clark over 5 years ago

I submitted a fix into nightlies, please test

38053bd1c0a3f9b762f26ab71159fa808e2ae661

#7 Updated by Erin Clark over 5 years ago

  • Status changed from Screened to Ready For Release
  • Target version set to Unspecified
  • ChangeLog Entry updated (diff)

#8 Updated by Jordan Hubbard over 5 years ago

  • Status changed from Ready For Release to Resolved

#9 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from Unspecified to N/A

#10 Updated by Dru Lavigne almost 3 years ago

  • File deleted (var-log-msgs.txt)

Also available in: Atom PDF