Project

General

Profile

Bug #83235

Do not allow a password to be set on an encrypted pool if it is set as the "System Dataset"

Added by Bonnie Follweiler over 2 years ago. Updated over 2 years ago.

Status:
Ready for Testing
Priority:
No priority
Assignee:
Waqar Ahmed
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When a clean install is done there is no device set as the system dataset (not even the boot drive)
The system dataset is assigned to the first pool created after the clean install - even if it is an encrypted pool
The console is throwing error messages.

So I will create a bug ticket for the system dataset to be set to the boot pool, by default, if no pool is available.
This ticket is a suggestion that we not allow a passphrase to be created if the pool is being used as the system dataset

Create an encrypted pool.png (116 KB) Create an encrypted pool.png Bonnie Follweiler, 03/21/2019 12:15 PM
Recovery Key.png (113 KB) Recovery Key.png Bonnie Follweiler, 03/21/2019 12:15 PM
Clean Install no pool.png (35.2 KB) Clean Install no pool.png Bonnie Follweiler, 03/21/2019 12:15 PM
unlocked pool created.png (54.8 KB) unlocked pool created.png Bonnie Follweiler, 03/21/2019 12:15 PM
Automatically assigned on creation.png (55 KB) Automatically assigned on creation.png Bonnie Follweiler, 03/21/2019 12:15 PM
create a passphrase.png (35.4 KB) create a passphrase.png Bonnie Follweiler, 03/21/2019 12:15 PM
passphrase created.png (35.1 KB) passphrase created.png Bonnie Follweiler, 03/21/2019 12:15 PM
lock the pool.png (47.3 KB) lock the pool.png Bonnie Follweiler, 03/21/2019 12:15 PM
locked pool.png (41.4 KB) locked pool.png Bonnie Follweiler, 03/21/2019 12:15 PM
errors.png (21.6 KB) errors.png Bonnie Follweiler, 03/21/2019 12:15 PM
62195
62203
62211
62219
62227
62235
62243
62251
62259
62267

Related issues

Related to FreeNAS - Bug #29106: Remove note from Guide and tooltip that incorrectly stated encrypted pools could not be used for the system datasetDone
Related to FreeNAS - Bug #83243: In a Clean Install, set the boot pool as the system dataset, by defaultClosed
Related to FreeNAS - Bug #71971: Do not allow an encrypted pool to be locked if it is being used for system dataset Closed

Associated revisions

Revision ef7b320b (diff)
Added by Waqar Ahmed over 2 years ago

Donot allow locking of a pool hosting system dataset This commit makes sure that we do not allow an encrypted pool to be locked if it hosts the system dataset. Ticket: #83235

History

#1 Updated by Bonnie Follweiler over 2 years ago

  • Related to Bug #29106: Remove note from Guide and tooltip that incorrectly stated encrypted pools could not be used for the system dataset added

#2 Updated by Bonnie Follweiler over 2 years ago

  • Related to Bug #83243: In a Clean Install, set the boot pool as the system dataset, by default added

#3 Updated by Bonnie Follweiler over 2 years ago

This issue is also in https://redmine.ixsystems.com/issues/71971 targeted for 11.3-Beta1
That ticket's status is "Blocked"

#4 Updated by Waqar Ahmed over 2 years ago

  • Assignee changed from William Grzybowski to Waqar Ahmed
  • Target version changed from Backlog to 11.2-U4

#5 Updated by Bug Clerk over 2 years ago

  • Status changed from Unscreened to In Progress

#7 Updated by Bug Clerk over 2 years ago

  • Status changed from In Progress to Ready for Testing

#9 Updated by Dru Lavigne over 2 years ago

  • Subject changed from Do not allow a password to be set on an encrypted pool is it is set as the "System Dataset" to Do not allow a password to be set on an encrypted pool if it is set as the "System Dataset"
  • Private changed from Yes to No

#10 Updated by Dru Lavigne over 2 years ago

  • Related to Bug #71971: Do not allow an encrypted pool to be locked if it is being used for system dataset added

Also available in: Atom PDF