Project

General

Profile

Bug #83243

In a Clean Install, set the boot pool as the system dataset, by default

Added by Bonnie Follweiler over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Behaves as Intended
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When I do a clean install there is no device/pool set as the system dataset until I create a pool
I am suggesting that we set the boot pool as the system default if there is no pool
I believ there is already a ticket to prevent a passphrase being added to an encrypted pool if it is also set as the system dataset. I will find that ticket as well

Clean Install no pool.png (35.2 KB) Clean Install no pool.png Bonnie Follweiler, 03/21/2019 12:24 PM
62275

Related issues

Related to FreeNAS - Bug #83235: Do not allow a password to be set on an encrypted pool if it is set as the "System Dataset"Ready for Testing

History

#1 Updated by Bonnie Follweiler over 2 years ago

  • Related to Bug #83235: Do not allow a password to be set on an encrypted pool if it is set as the "System Dataset" added

#2 Updated by Eric Loewenthal over 2 years ago

If the system dataset doesn't automatically get migrated off of the boot pool once something else is available, this could be a problem for anyone booting from USB flash drives.

#3 Updated by William Grzybowski over 2 years ago

  • Status changed from Unscreened to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Behaves as Intended

Also available in: Atom PDF