Project

General

Profile

Bug #8333

File bug not working

Added by Torkil Svensgaard over 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Internal Server Error

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application.


Related issues

Copied to FreeNAS - Bug #8383: Support UI internal error while validating credentialsResolved2015-03-02

Associated revisions

Revision 1f6876df (diff)
Added by William Grzybowski over 5 years ago

Make sure category has been selected Which won't happen if user/password were not validated. Ticket: #8333

Revision fb119186 (diff)
Added by William Grzybowski over 5 years ago

Make sure category has been selected Which won't happen if user/password were not validated. Ticket: #8333 (cherry picked from commit 1f6876df461e1752d49c7471f48ae63b33cc5dea)

Revision 261e78cf (diff)
Added by William Grzybowski over 5 years ago

Make sure category has been selected Which won't happen if user/password were not validated. Ticket: #8333 (cherry picked from commit 1f6876df461e1752d49c7471f48ae63b33cc5dea)

History

#1 Updated by Torkil Svensgaard over 5 years ago

2296

I guess not entirely true, but still.

#2 Updated by Jordan Hubbard over 5 years ago

  • Category set to 135
  • Assignee set to Erin Clark

#3 Updated by Erin Clark over 5 years ago

  • Status changed from Unscreened to Screened

#4 Updated by William Grzybowski over 5 years ago

The error here is that the user/password are not valid (categories have not been filled). However it shouldn't be a fatal error on the proxy (500).

#5 Updated by Jordan Hubbard over 5 years ago

  • Assignee changed from Erin Clark to William Grzybowski

Well, if the username / password are not valid and the categories have not even been filled yet, why is the support UI even attempting to send the ticket through the proxy? The submit button should be greyed out (or at least bring up a popup saying "Not so fast, bucko - your username and password are incorrect!") until it is safe to proceed.

#6 Updated by William Grzybowski over 5 years ago

A popup does say that! However the user ignored it and clicked submit anyway.

#7 Updated by Jordan Hubbard over 5 years ago

OK, so, let's change the behavior then. No submitting until everything checks out. There's no point in allowing the user to proceed if we can't do anything with their submission.

#8 Updated by William Grzybowski over 5 years ago

Either way the proxy should be fixed, not software in the world should bomb out based on bad user input.

#9 Updated by Jordan Hubbard over 5 years ago

I agree that the proxy should be toughened against error. However, let's also go for defense-in-depth. First make sure things are really good to proceed from the GUI, and don't allow the user to proceed until they are, and then hand this back to Erin to also do something reasonable with other types of user errors if some can still get through. It's not even clear to me what sort of "bogus input" can be handed to the Proxy after the user authentication has been validated.

#10 Updated by William Grzybowski over 5 years ago

I am not saying I won't do it, just saying both fronts should be fixed.

#11 Updated by William Grzybowski over 5 years ago

Although I cannot reproduce the issue and I believe he got this error while Erin was changing the proxy or fixed already.

#12 Updated by William Grzybowski over 5 years ago

  • Status changed from Screened to Ready For Release

#13 Updated by William Grzybowski over 5 years ago

  • Target version set to Unspecified

#14 Updated by Torkil Svensgaard over 5 years ago

Probably doesn't matter, since you seem to have a handle on this, but I'm pretty sure I had entered the right credentials and I got the error when I tabbed out of the user/password fields. I had just reset my password and used the new one to log into the website, and I tried with the very same credentials in the UI, to no avail. This bug was posted from the UI with the error showing, so it partially worked.

#15 Updated by Torkil Svensgaard over 5 years ago

William Grzybowski wrote:

Although I cannot reproduce the issue and I believe he got this error while Erin was changing the proxy or fixed already.

Still getting the error, for the record

#16 Updated by William Grzybowski over 5 years ago

Torkil Svensgaard wrote:

William Grzybowski wrote:

Although I cannot reproduce the issue and I believe he got this error while Erin was changing the proxy or fixed already.

Still getting the error, for the record

Yeah, I would expect to, since no update has been released yet.

However I am still curious why. Would you be willing to do a TeamViewer to troubleshoot this?

#17 Updated by Torkil Svensgaard over 5 years ago

William Grzybowski wrote:

Torkil Svensgaard wrote:

William Grzybowski wrote:

Although I cannot reproduce the issue and I believe he got this error while Erin was changing the proxy or fixed already.

Still getting the error, for the record

Yeah, I would expect to, since no update has been released yet.

However I am still curious why. Would you be willing to do a TeamViewer to troubleshoot this?

That was in response to you not being able to reproduce it.

Sure, should I email you the credentials?

#18 Updated by William Grzybowski over 5 years ago

Torkil Svensgaard wrote:

William Grzybowski wrote:

Torkil Svensgaard wrote:

William Grzybowski wrote:

Although I cannot reproduce the issue and I believe he got this error while Erin was changing the proxy or fixed already.

Still getting the error, for the record

Yeah, I would expect to, since no update has been released yet.

However I am still curious why. Would you be willing to do a TeamViewer to troubleshoot this?

That was in response to you not being able to reproduce it.

Sure, should I email you the credentials?

Yes please,

#19 Updated by William Grzybowski over 5 years ago

  • Copied to Bug #8383: Support UI internal error while validating credentials added

#20 Updated by William Grzybowski over 5 years ago

Thanks, I've identified another issue and opened a new bug to track it.

#21 Updated by Jordan Hubbard over 5 years ago

  • Status changed from Ready For Release to Resolved

#22 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from Unspecified to N/A

Also available in: Atom PDF