Project

General

Profile

Bug #83907

Console Setup menu option "1) Configure Network Interface" doesn't allow configuration, breaks networking.

Added by Karl Fife over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Warren Block
Category:
Documentation
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

It appears that Console Menu option
"1) Configure Network Interface"
does not allow network configuration, and can break an existing good config.

Assuming the expected behavior is correctly documented in section 3.1 "Obtaining an IP address" in https://www.ixsystems.com/documentation/freenas/11.2/booting.html

Expected behavior:
Prompts for networking parameters, applies them.

Observed behavior:
Menu does not prompt for networking parameters, exits prematurely, leaving network configuration incomplete or broken.

Steps to reproduce:
On a new install, from the console setup menu on a default config, select option 1 to Configure Network Interface.

Enter an option 1-11:
1) em0
Select an interface (q to quit): 1
Reset network configuration? (y/n) y
Resetting interface configuraiton: Ok
Restarting network: ok
Restarting routing: ok

Console Setup
...
The web interface could not be accessed.
Please check network configuration

Note:

If the system had no explicit networking config, rebooting the system in this state will bring the interface and the WebUI back up (presumably in a default configuration).

If the system had an existing good config for a real interface (e.g. em0), the console menu system will properly prompt to delete the existing config, but will not prompt for new settings. The network will not come up without a reboot (again, presumably in a default configuration).

If there is a problematic config (e.g. an imported config with settings that are inappropriate to a new piece of hardware (ix0 vs em0) or a config inappropriate to a new network environment), the system can't be recovered without dropping to shell to manually configure networking, enabling the GUI, enabling proper reconfiguration.

History

#1 Updated by Dru Lavigne over 2 years ago

  • Category changed from Console to Documentation
  • Assignee changed from Release Council to Warren Block
  • Target version changed from Backlog to 11.2-U4

We should probably add a note to clarify:
Reset network configuration (y/n) n

to make it obvious that selecting n means you want to edit the configuration but selecting y means that you want to reload the current configuration without editing it.

#2 Updated by Warren Block over 2 years ago

  • Status changed from Unscreened to Screened

The root cause is that this is not really a yes/no question. We need to fix the prompt to make clear what it actually does. Maybe:

Restore this interface to saved configuration?

#3 Updated by Karl Fife over 2 years ago

+1 "Restore this interface to saved configuration?"

'reset' is ambiguous because it can connote making a change.

Assuming the prompts are clarified, isn't there also a technical issue (given that 'restoring the interface to saved configuration' takes the interface offline)?

#4 Updated by Jaron Parsons over 2 years ago

  • Status changed from Screened to Closed

Also available in: Atom PDF