Project

General

Profile

Bug #83908

Run ZFS operations in a process pool

Added by Bug Clerk over 1 year ago. Updated over 1 year ago.

Status:
Done
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
Yes

Description

Tried to create a periodic snapshot task, and could no create it. After clicking save, the WebGUI rejects the dataset chosen saying "Select a valid choice. tank/Backups/Dropbox is not one of the available choices." This is a bit whimsical since it is a dropdown.

I can reproduce this trivially. If a dev would like to see and debug this on my personal FreeNAS, have them contact me via Ryver.


Related issues

Copied from FreeNAS - Bug #76971: Run ZFS operations in a process pool Done

Associated revisions

Revision db0da103 (diff)
Added by William Grzybowski over 1 year ago

Fix bad merge for LoadPluginsMixin Ticket: #83908

History

#1 Updated by Bug Clerk over 1 year ago

  • Copied from Bug #76971: Run ZFS operations in a process pool added

#2 Updated by Bug Clerk over 1 year ago

  • Target version changed from Master - FreeNAS Nightlies to 11.2-U4

#3 Updated by Bug Clerk over 1 year ago

  • Status changed from Unscreened to In Progress

#4 Updated by Bug Clerk over 1 year ago

  • Status changed from In Progress to Ready for Testing

#5 Updated by Dru Lavigne over 1 year ago

  • Subject changed from Periodic Snapshot task cannot be created - Dropdown is identified as "invalid" to Run ZFS operations in a process pool
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#6 Updated by William Grzybowski over 1 year ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

#8 Updated by Dru Lavigne over 1 year ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF