Project

General

Profile

Bug #8466

Unable to install plugins /jails issue

Added by shaun whitehead over 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
John Hixson
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Originally unable to install plugins getting:

freenas installing plugin error unable to find template

I was running 9.2.? so did an in place upgrade to FreeNAS-9.3-STABLE-201503071634.GUI_Upgrade.txz

The problem persisted after upgrade.

After looking across the forums this post had a lot of symptoms i had been experiencing - https://bugs.freenas.org/issues/4845#note-7?

after running -
python /usr/local/www/freenasUI/manage.py migrate jails 0006
python /usr/local/www/freenasUI/manage.py migrate jails

service django stop
service django start

i now get the error message failed to generate navtree for app freenasui.jails: no such column: jails_jailsconfiguration.jc_ipv4_dhcp and can no longer see my jails menu in the gui with the error showing.

All my previously installed plugins are still working away.

template.jpg (14.4 KB) template.jpg shaun whitehead, 03/09/2015 01:41 PM
2389

History

#1 Updated by shaun whitehead over 5 years ago

  • File ixdiagnose.tgz added

#2 Updated by John Hixson over 5 years ago

  • Status changed from Unscreened to 15
  • Target version set to Unspecified

This sounds like you've got a borked upgrade and/or you've been fiddling with database migrations (as noted). Can you do the following from the command line?

sqlite3 /data/freenas-v1.db "select * from south_migrationhistory where app_name = 'jails';"

Post the output to this ticket please.

#3 Updated by shaun whitehead over 5 years ago

Output as requested cheers

[root@weiss-nas] ~# sqlite3 /data/freenas-v1.db "select * from south_migrationhistory where app_name = 'jails';"
265|jails|0001_add_model_JailsConfiguration|2014-08-27 09:37:48.536749
266|jails|0002_auto__add_field_jailsconfiguration_jc_ipv4_network__add_field_jailscon|2014-08-27 09:37:48.768497
267|jails|0003_add_model_NullMountPoint|2014-08-27 09:37:48.835973
268|jails|0004_add_field_NullMountPoint_jail|2014-08-27 09:37:48.970107
269|jails|0005_add_field_JailsConfiguration_jc_ipv4_network_start_add_field_JailsConfiguration_jc_ipv4_network_end_add_field_JailsConfiguration_jc_ipv6_network_start_add_field_JailsConfiguration_jc_ipv6_network_end|2014-08-27 09:37:49.418988
270|jails|0006_add_field_JailsConfiguration_jc_collectionurl|2014-08-27 09:37:49.563618
271|jails|0007_add_model_JailTemplate|2014-08-27 09:37:50.821580
272|jails|0008_auto__chg_field_jails_jail_defaultrouter_ipv6__add_field_nullmountpoint_readonly|2014-08-27 09:37:52.070783
273|jails|0009_remove_centos|2014-08-27 09:37:52.106155
274|jails|0010_add_9_2_0_release_templates|2014-08-27 09:37:52.185258

#4 Updated by John Hixson over 5 years ago

Shaun,

You are missing numerous migrations. Cleaning this up won't be easy. I recommend saving your config and re-installing. In the future I don't recommend messing with migrations ;-)

#5 Updated by shaun whitehead over 5 years ago

Already prepped for that possibility :)

#6 Updated by John Hixson over 5 years ago

shaun whitehead wrote:

Already prepped for that possibility :)

Can you do that and let me know how it goes?

#7 Updated by shaun whitehead over 5 years ago

2389

restored to factory settings from a backup i took of the freenas install from this morning before i did anything.

now back to the issue of the unable to install plugin get error unable to find template

#8 Updated by John Hixson over 5 years ago

shaun whitehead wrote:

restored to factory settings from a backup i took of the freenas install from this morning before i did anything.

now back to the issue of the unable to install plugin get error unable to find template

Okay. NO fiddling with migrations. Keep your system as is ;-) Do you have time to do a teamviewer session today? If so, let's agree on a time and shoot me your teamviewer info to

#9 Updated by shaun whitehead over 5 years ago

sent over my webex info to you

#10 Updated by John Hixson over 5 years ago

  • Status changed from 15 to Resolved

Shaun is sorted out now. There was a template directory in his jail root that wasn't correct. Nuked it from orbit, added the pluginjail template, then plugin installs worked again.

#11 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from Unspecified to N/A

#12 Updated by Stephen Griffiths about 4 years ago

  • Seen in changed from to 9.10.1

Could I possibly get more of a Explanation of what was deleted and How? Did you remove from Storage GUI what was removed, and how did you replace? Just add a new plugin? Manually?
I have multiple .warden-template-pluginjail's 9.2 9.3 standard having this same issue.

Thanks

#13 Updated by Dru Lavigne almost 3 years ago

  • File deleted (ixdiagnose.tgz)

Also available in: Atom PDF