Project

General

Profile

Bug #85012

Correctly write multiple ISNS servers to iSCSI configuration file

Added by Sergio Peirone over 2 years ago. Updated over 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Waqar Ahmed
Category:
Middleware
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No
Tags:

Description

I'm trying to activate Isi but I keep getting a message of error

Schermata 2019-04-04 alle 11.26.11.png (39.2 KB) Schermata 2019-04-04 alle 11.26.11.png Sergio Peirone, 04/04/2019 02:30 AM
Schermata 2019-04-04 alle 11.26.05.png (40 KB) Schermata 2019-04-04 alle 11.26.05.png Sergio Peirone, 04/04/2019 02:30 AM
Schermata 2019-04-04 alle 11.26.15.png (36.1 KB) Schermata 2019-04-04 alle 11.26.15.png Sergio Peirone, 04/04/2019 02:30 AM
Schermata 2019-04-04 alle 11.26.21.png (34.5 KB) Schermata 2019-04-04 alle 11.26.21.png Sergio Peirone, 04/04/2019 02:30 AM
Schermata 2019-04-04 alle 11.26.26.png (35.3 KB) Schermata 2019-04-04 alle 11.26.26.png Sergio Peirone, 04/04/2019 02:30 AM
Schermata 2019-04-04 alle 11.26.31.png (44.1 KB) Schermata 2019-04-04 alle 11.26.31.png Sergio Peirone, 04/04/2019 02:30 AM
Schermata 2019-04-04 alle 11.26.35.png (36 KB) Schermata 2019-04-04 alle 11.26.35.png Sergio Peirone, 04/04/2019 02:30 AM
Schermata 2019-04-04 alle 11.26.51.png (92.3 KB) Schermata 2019-04-04 alle 11.26.51.png Sergio Peirone, 04/04/2019 02:30 AM
freenas.mov (2.73 MB) freenas.mov Sergio Peirone, 04/04/2019 08:55 AM
63891
63899
63900
63908
63915
63923
63924
63931

Related issues

Copied to FreeNAS - Bug #85195: Correctly write multiple ISNS servers to iSCSI configuration fileReady for Testing

Associated revisions

Revision d404f4a1 (diff)
Added by Waqar Ahmed over 2 years ago

Correctly write multiple isns servers This commit fixes a bug where when we wrote isns-servers, we split on spaces only. Ticket: #85012

Revision 626b0fd0 (diff)
Added by Waqar Ahmed over 2 years ago

Correctly write multiple isns servers This commit fixes a bug where when we wrote isns-servers, we split on spaces only. Ticket: #85012 (cherry picked from commit d404f4a116966125b013139537a83d6cc4d7a965)

History

#1 Updated by Dru Lavigne over 2 years ago

  • Subject changed from But what am I wrong? to Can't start iSCSI service
  • Status changed from Unscreened to Blocked
  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Sergio: please reproduce then create a debug (System -> Advanced -> Save debug) and attach that to this ticket.

#2 Updated by Sergio Peirone over 2 years ago

  • File debug-Server nas nas-server-20190404123901.tgz added

Ops... sorry!

#3 Updated by Dru Lavigne over 2 years ago

  • Category changed from Services to OS
  • Status changed from Blocked to Unscreened
  • Assignee changed from Release Council to Alexander Motin
  • Reason for Blocked deleted (Need additional information from Author)

#4 Updated by Alexander Motin over 2 years ago

  • Category changed from OS to Middleware
  • Assignee changed from Alexander Motin to William Grzybowski

Sergio, the problem seem to be in the list of iSNS servers, which were incorrectly written into CTL configuration file. Hint in UI tells they should be separated by spaces, while in your case I see new-lines.

William, I see there space for improvement. ;)

#5 Updated by William Grzybowski over 2 years ago

  • Assignee changed from William Grzybowski to Waqar Ahmed
  • Target version changed from Backlog to 11.2-U4

#7 Updated by Sergio Peirone over 2 years ago

I did, too, but because I separated with space and freenas saved him with lines, assumed that he was normal.
OK, I'd say it s bug at this point.
Pending correction, how can I solve this?

#8 Updated by Sergio Peirone over 2 years ago

That's what happens

#9 Updated by Bug Clerk over 2 years ago

  • Status changed from Unscreened to In Progress

#10 Updated by Bug Clerk over 2 years ago

  • Copied to Bug #85195: Correctly write multiple ISNS servers to iSCSI configuration file added

#11 Updated by Bug Clerk over 2 years ago

  • Status changed from In Progress to Ready for Testing

#12 Updated by Bug Clerk over 2 years ago

  • Target version changed from 11.2-U4 to 11.3-BETA1

#13 Updated by Dru Lavigne over 2 years ago

  • File deleted (debug-Server nas nas-server-20190404123901.tgz)

#14 Updated by Dru Lavigne over 2 years ago

  • Subject changed from Can't start iSCSI service to Correctly write multiple ISNS servers to iSCSI configuration file
  • Status changed from Ready for Testing to Done
  • Target version changed from 11.3-BETA1 to Master - FreeNAS Nightlies
  • Private changed from Yes to No
  • Needs QA changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

Also available in: Atom PDF