Project

General

Profile

Bug #869

Active Directory and homes share

Added by Francesco - almost 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Important
Assignee:
-
Category:
Middleware
Target version:
-
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hi, I managed to configure AD in [[FreeNAS]] (against Resara Server) and configured homes shares on a ZFS dataset.
The problem was users can access other shares with AD groups permissions but cannot access their homes.
After one day I found in /etc/local/samba/smb.conf under [homes] share that valid users was set to %S (the service name which is resolved with the user name less DOMAIN!!!)
I changed that line with %U (the client supplied username) and it worked (after setting permissions from console).
The problem is that whenever I restart CIFS or something related with it the file smb.conf is rewritten and again I have %S instead of %U.
Where is the script which writes smb.conf to correct it?

History

#1 Updated by Anonymous over 8 years ago

  • Status changed from Unscreened to Closed

Resolved in r8241.

#2 Updated by yaberauneya - over 8 years ago

In [8241/freenas]:

#!CommitTicketReference repository="freenas" revision="8241" 
e %U instead of %S.

Using %S instead of %U was a documentation bug, as noted by a bug filer on:
https://bugzilla.samba.org/show_bug.cgi?id=7766 .

Verified with my Macbook by connecting to <foo>/homes/ and verifying that <foo>/homes/<user> reflected the appropriate changes to the share.

This addresses ticket 869.

Also available in: Atom PDF