Project

General

Profile

Bug #873

Deleting ZFS dataset from GUI doesn't delete from system in all cases; leaves orphaned data/dataset

Added by Anonymous over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Expected
Assignee:
William Grzybowski
Category:
GUI (new)
Target version:
-
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

There are some scenarios where one or more customers have run into issues deleting datasets from the GUI, where the dataset has been removed from the GUI but not from the backend.

Trying to readd the dataset from the GUI fails.

Part of the problem is most likely that the commit operation is backwards and/or incorrect, e.g. datasets should be deleted IFF the data in the dataset, snapshots, etc have been purged from the system.

Sources are based off of 8.0.1-RC2//-RC3 equivalent sources.

Currently gathering data.. will provide a presentable reproduction case soon.

History

#1 Updated by William Grzybowski over 7 years ago

Datasets no longer rely on database, since r8423. A few other minor bugs and error feedback have been fixed.

Also available in: Atom PDF