Project

General

Profile

Feature #91

Hybrid Flash+HD install option

Added by wxop - almost 11 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Important
Assignee:
-
Category:
Middleware
Target version:
-
Estimated time:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Description

While installing [[FreeNAS]], we should be allowed to install it on multiple Disks and/or Partitions (like most Linux installers currently do):

It should be possible (and easy) to install "/" on an (USB or compact) flash disk while having "/var/" , "/tmp/" and Swap installed on Hard Drive Partitions.

The GUI should then allow to easely:
- reinstall either the flash device, either the Hard Drive
- backup/restore configuration(s) between the flash device and the Hard Drive

This would allow to get an almost indestructible system on an (easely interchangeable and update-able) flash disk, while keeping files that need frequent and fast accesses, on the Hard Drive.

The goal is no have a NAS that you can "setup and forget" while stilll being able to easely and fastly repair when anything goes wrong (update brokes everything, hard disk failures, bad plug-in...). This is even more important if you include home-automation plug-ins, as recently announced!

(Sorry for my English)

History

#1 Updated by Joe Schmuck almost 9 years ago

Since my ticket was cancelled stating it was a duplicate of this ticket (which I don't agree with), I thought I'd post my ticket comments here.

Now that we are years into this project and the price of SSD's are dropping like crazy, it makes sense for someone building a system to consider purchasing a SSD.

This may go against some peoples beliefs but if you think about SSD's then this makes complete sense. It cost's me under $50.00 US for a 32GB SSD right now. If I were to buy a SSD as a boot device, I'd like to have the option to use the other ~28GB of the drive if possible. What I suggest if that during the installation that if the loader detects that the drive where the OS is being loaded to has maybe 3GB (pick whatever value makes sense) larger than the image needs, that an option becomes available to create the remaining space of the drive as a single UFS partition.

#2 Updated by Jordan Hubbard almost 8 years ago

  • Status changed from Unscreened to Closed

Given that we're moving away from UFS, I just don't see the likelihood of this ever being a priority. Any larger SSDs should be dedicated to ZIL or L2ARC roles.

#3 Updated by Jordan Hubbard over 6 years ago

  • Target version deleted (2)

Also available in: Atom PDF