Project

General

Profile

Bug #9227

Can't read Plugin Page from Web interface

Added by Ermanno Gnan over 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Environment:

Software Version: FreeNAS-9.3-STABLE-201504100216
Request Method: GET
Request URL: http://192.168.1.8/plugins/plugin/home/?dojo.preventCache=1429106730468

Traceback:
File "/usr/local/lib/python2.7/site-packages/django/core/handlers/base.py" in get_response
105. response = middleware_method(request, callback, callback_args, callback_kwargs)
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/middleware.py" in process_view
157. return login_required(view_func)(request, *view_args, **view_kwargs)
File "/usr/local/lib/python2.7/site-packages/django/contrib/auth/decorators.py" in _wrapped_view
22. return view_func(request, *args, **kwargs)
File "/usr/local/www/freenasUI/../freenasUI/plugins/views.py" in home
94. reset_plugin_progress()
File "/usr/local/www/freenasUI/../freenasUI/plugins/views.py" in reset_plugin_progress
78. jc = JailsConfiguration.objects.order_by("-id")[0]
File "/usr/local/lib/python2.7/site-packages/django/db/models/query.py" in getitem
132. return list(qs)[0]

Exception Type: IndexError at /plugins/plugin/home/
Exception Value: list index out of range

Schermata 2015-04-15 alle 16.13.53.png (286 KB) Schermata 2015-04-15 alle 16.13.53.png It happens when I click "Plugins" Ermanno Gnan, 04/15/2015 07:14 AM
2689

Related issues

Is duplicate of FreeNAS - Bug #9290: Plugins Exception Type IndexErrorClosed: Duplicate2015-04-17
Is duplicate of FreeNAS - Bug #9294: Plugins not availableClosed: Duplicate2015-04-17

Associated revisions

Revision 89672a34 (diff)
Added by William Grzybowski over 5 years ago

Auto configure jails if applicable Ticket: #9227 Merge-FN93: yes Merge-TN93: yes

Revision 62f4d60d (diff)
Added by William Grzybowski over 5 years ago

Auto configure jails if applicable Ticket: #9227 Merge-FN93: yes Merge-TN93: yes (cherry picked from commit 89672a34ab8868ec99bd12d2810b4431f7db6318)

Revision 87f62053 (diff)
Added by William Grzybowski over 5 years ago

Auto configure jails if applicable Ticket: #9227 Merge-FN93: yes Merge-TN93: yes (cherry picked from commit 89672a34ab8868ec99bd12d2810b4431f7db6318)

History

#1 Updated by Ermanno Gnan over 5 years ago

It happens if no jail is configured and linked to a ZFS volume!

#2 Updated by Jordan Hubbard over 5 years ago

  • Category set to 33
  • Assignee set to William Grzybowski
  • Priority changed from Important to Nice to have
  • Target version set to Unspecified

Hmmm. First time I've seen one of these with a traceback! Over to William.

#3 Updated by William Grzybowski over 5 years ago

  • Status changed from Unscreened to Screened

#4 Updated by William Grzybowski over 5 years ago

  • Status changed from Screened to Ready For Release
  • ChangeLog Entry updated (diff)

#5 Updated by William Grzybowski over 5 years ago

  • Is duplicate of Bug #9290: Plugins Exception Type IndexError added

#6 Updated by William Grzybowski over 5 years ago

  • Is duplicate of Bug #9294: Plugins not available added

#7 Updated by Mahdi - over 5 years ago

Ermanno Gnan wrote:

It happens if no jail is configured and linked to a ZFS volume!

Confirmed... create a jail, link it to a ZFS volume... list loads.

#8 Updated by Mahdi - over 5 years ago

^ Rather specify jail directory in configuration.

#9 Updated by Jordan Hubbard over 5 years ago

  • Status changed from Ready For Release to Resolved

#10 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from Unspecified to N/A

Also available in: Atom PDF