Project

General

Profile

Bug #9730

Guide Link on Sidebar

Added by Stephen Griffiths over 5 years ago. Updated about 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
Nice to have
Assignee:
Sean Fagan
Category:
Documentation
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

After Updating the "Guide" link on the side bar and also the Guide like on top right just have a 404 Error.
404 Not Found

nginx/1.6.2

Have other Freenas boxes that this URL works fine.

Since I could not search and find any one else with this issue I figured it was a Bug that is too new to be discussed yet. Does not affect system just cool link to have and annoying it does not work.
also did not join domain after Upgrade had to do manually after restart.

404_not_found_Freenas.PNG (67.6 KB) 404_not_found_Freenas.PNG Stephen Griffiths, 05/11/2015 07:09 PM
2873

History

#1 Updated by Stephen Griffiths over 5 years ago

  • File ixdiagnose.tgz added

#2 Updated by Stephen Griffiths over 5 years ago

2873

#3 Updated by Stephen Griffiths over 5 years ago

  • Subject changed from Guild Link on Sidebar to Guide Link on Sidebar

#4 Updated by Suraj Ravichandran over 5 years ago

  • Category changed from 78 to Documentation
  • Assignee changed from Suraj Ravichandran to Anonymous

#5 Updated by Anonymous over 5 years ago

  • Status changed from Unscreened to Screened
  • Estimated time set to 1.00 h

Okay, got it.

#6 Updated by Anonymous over 5 years ago

  • Status changed from Screened to 15

Stephen: This didn't happen on fresh install. What exact version did you upgrade from?

Also, if you're still having that issue joining the domain, that's much more serious, so please make sure there's already a bug for that.

#7 Updated by Stephen Griffiths over 5 years ago

Ben Milman wrote:

Stephen: This didn't happen on fresh install. What exact version did you upgrade from?

Also, if you're still having that issue joining the domain, that's much more serious, so please make sure there's already a bug for that.

Version before Update: FreeNAS-9.3-STABLE-201501241715

After boot time I could Join Domain No problem, It just did not join during boot.
Only issues at this time is the "Guide" Link is broken says 404, and I get these constant Samba messages but that has been in every version.

#8 Updated by Anonymous over 5 years ago

  • Status changed from 15 to Investigation

Okay. I just meant that if it's still not joining automatically after reboot, that's an issue.

I was able to duplicate your docs issue by updating from the version you named to the most recent version using the online update method. The entire docs directory is simply missing. However, upgrading between more recent versions don't have the issue. I would infer that it's because 201501241715 was before the docs buttons (and embedded directory) were introduced. Upgrading using the manual process also appears to avoid the issue.

I'm going to look for a workaround and seek out what caused the issue.

#9 Updated by Anonymous over 5 years ago

  • Status changed from Investigation to Unscreened
  • Assignee changed from Anonymous to Sean Fagan
  • Target version set to Unspecified

So, reproduction case:

1. Start with a FreeNAS install of a version before there were docs in the GUI. Starting with FreeNAS-9.3-STABLE-201501241715 works, as an example.
2. Use the automatic update process.
Result: The two GUI Guide buttons lead to 404s. Looking for the files in /usr/local/www/data/docs/ shows that they're simply not there.

Workaround: Perform a manual upgrade instead.

I don't think I'm able to actually solve the problem; Suraj suggests that it's due to the docs not being included in the new upgrade process. Therefore, over to you, Sean. Please let me know if you need any more information.

#10 Updated by Sean Fagan over 5 years ago

The issue was the older version of the update code had a bug when installing a new package, that caused it to, in fact, not install the new package.

The next update will do the right thing. Alternately, you could go back to the previous version, switch to the Nightlies train, update, then from that switch to the stable train and update again.

Bugs in the installation/update code tend to require a two-stage process.

Alternately, it's possible to install the package manually.

#11 Updated by Stephen Griffiths over 5 years ago

Sean Fagan wrote:

The issue was the older version of the update code had a bug when installing a new package, that caused it to, in fact, not install the new package.

The next update will do the right thing. Alternately, you could go back to the previous version, switch to the Nightlies train, update, then from that switch to the stable train and update again.

Bugs in the installation/update code tend to require a two-stage process.

Alternately, it's possible to install the package manually.

I did another update as suggested and the Guide links work now. Only issues are failure to rejoin domain at boot time and the never ending samba messages. Manual join to domain works fine. Thank you all for your responses.

#12 Updated by Jordan Hubbard over 5 years ago

  • Status changed from Unscreened to Closed: Cannot reproduce

#13 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from Unspecified to N/A

#14 Updated by Dru Lavigne about 3 years ago

  • File deleted (ixdiagnose.tgz)

#15 Updated by Dru Lavigne about 3 years ago

  • Private changed from Yes to No

Also available in: Atom PDF