Project

General

Profile

Bug #9776

Syslog-ng filling up logs

Added by Jeren Suzuki over 6 years ago. Updated over 4 years ago.

Status:
Closed: Cannot reproduce
Priority:
Nice to have
Assignee:
Jordan Hubbard
Category:
Forums/Websites
Target version:
-
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Forgot since when it started, but it's persistent across reboots.

Under System > System Dataset, Syslog is unchecked and reporting database is unchecked.

History

#1 Updated by Jeren Suzuki over 6 years ago

  • File ixdiagnose.tgz added

#2 Updated by William Grzybowski over 6 years ago

  • Status changed from Unscreened to Screened

Did you make any changes to the system root? This /dev/console not configured doesn't make sense.

Did you change the console keyboard map?

#3 Updated by Jeren Suzuki over 6 years ago

I don't recall making changes to the system root - is there a way I can check?

Regarding the console keyboard map, I'm almost 100% sure I didn't change that.

#4 Updated by William Grzybowski over 6 years ago

Can you try shutting down the Jails and make sure the problem persists?

Also can you paste "ls -lR /dev"?

#5 Updated by Jeren Suzuki over 6 years ago

  • File output.txt added

Jails have been stopped, output of ls -lR /dev is below

#6 Updated by William Grzybowski over 6 years ago

Does the problem persist after shutting them down?

#7 Updated by Jeren Suzuki over 6 years ago

Don't see any in console yet, should I disable auto-start on the jails and restart?

#8 Updated by William Grzybowski over 6 years ago

Yes, give it a try please.

#9 Updated by Jeren Suzuki over 6 years ago

Restarted, errors still present. Jails are not running.

#10 Updated by William Grzybowski over 6 years ago

  • Private changed from Yes to No

#11 Updated by William Grzybowski over 6 years ago

  • Assignee changed from William Grzybowski to Jordan Hubbard

I am out of ideas here, I cannot reproduce the issue.

Jordan?

#12 Updated by Jordan Hubbard over 6 years ago

  • Status changed from Screened to Closed: Cannot reproduce

I can't reproduce it either - something about this person's box is hosed (in a way we can do nothing about). Setting as Cannot Reproduce.

#13 Updated by Julien F. about 5 years ago

  • Category changed from 55 to 32
  • Seen in changed from 9.3-STABLE-201505130355 to 9.10.1

It is still happening, and even reinstalling freenas on a new stick from scratch could not stop this error to appear every minute.

Aug 9 21:32:06 freenas syslog-ng2215: Error opening file for writing; filename='/dev/console', error='Device not configured (6)'
Aug 9 21:33:06 freenas syslog-ng2215: Error opening file for writing; filename='/dev/console', error='Device not configured (6)'
Aug 9 21:34:06 freenas syslog-ng2215: Error opening file for writing; filename='/dev/console', error='Device not configured (6)'
Aug 9 21:35:07 freenas syslog-ng2215: Error opening file for writing; filename='/dev/console', error='Device not configured (6)'
Aug 9 21:35:07 freenas syslog-ng2215: Error opening file for writing; filename='/dev/console', error='Device not configured (6)'
Aug 9 21:36:07 freenas syslog-ng2215: Error opening file for writing; filename='/dev/console', error='Device not configured (6)'

#14 Updated by scott maverick over 4 years ago

This same issue has started for me as well in the last month. Had been running fine for several months prior and I had not made any changes to configs or root. I just installed new updates but the problem persists.

Build: FreeNAS-9.10.2-U1 (86c7ef5)

Jan 31 20:49:59 freenas syslog-ng1554: Error opening file for writing; filename='/dev/console', error='Device not configured (6)'
Jan 31 20:50:59 freenas syslog-ng1554: Error opening file for writing; filename='/dev/console', error='Device not configured (6)'
Jan 31 20:51:59 freenas syslog-ng1554: Error opening file for writing; filename='/dev/console', error='Device not configured (6)'
Jan 31 20:52:59 freenas syslog-ng1554: Error opening file for writing; filename='/dev/console', error='Device not configured (6)'
Jan 31 20:53:59 freenas syslog-ng1554: Error opening file for writing; filename='/dev/console', error='Device not configured (6)'
Jan 31 20:54:59 freenas syslog-ng1554: Error opening file for writing; filename='/dev/console', error='Device not configured (6)'

#15 Updated by Dru Lavigne over 4 years ago

Please create a new bug as this one is over a year old. Include your debug (from System -> Advanced -> Save Debug) in the new ticket.

#16 Updated by Dru Lavigne almost 4 years ago

  • File deleted (ixdiagnose.tgz)

#17 Updated by Dru Lavigne almost 4 years ago

  • File deleted (output.txt)

Also available in: Atom PDF