Project

General

Profile

Bug #9899

RSync Task receives permission error when Task is 'Run Now' but no permission errors when Task is run according to schedule.

Added by Benjamin Gilles over 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Expected
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I have a Rsync task configured for Module Mode that is syncing all data to an older Synology NAS Box.

The data I am trying to sync is 4 CIFS shares. 2 of the 4 shares I have removed the 'Everyone' group from access by adjusting this from Windows as the documentation suggests.

The rsync task is configured to use a user 'rsync' that has been assigned the same groups as the 4 shares in the task.

Of the 4 shares I am having an issue with just the 2 shares that I have removed the 'Everyone' group from, but only when using the 'Run Now' option.

When using the 'Run Now' option, the task reports a permission error as seen in the screenshots attached.

If the same task is allowed to run from the assigned schedule which I had set-up to run at 11:03 P.M. just to demonstrate this issue, the rsync task can run and back up all 4 directories with no issues.

Is there a difference in how the task is run or users involved with using the 'Run Now' button vs. the scheduled method that would account for this difference in behavior?

Also as a side note my first version of this task was to attempt to do this rsync over ssh on Port 22. After switching back to module mode the Port Number is still displayed in the GUI. Not a big deal but can be a little misleading since we are not technically using 22 anymore. This is also in the screenshot.

I do also have extra parameters in this rsync task that I will include in the screenshot as well, I do not believe these are the issue though as the Task runs fine when ran according to schedule. Issue only presents itself when the 'Run Now' button is used.

RsyncConfig.jpg (30 KB) RsyncConfig.jpg Benjamin Gilles, 06/12/2015 08:37 AM
RsyncFreeNASPerms.jpg (41.6 KB) RsyncFreeNASPerms.jpg Benjamin Gilles, 06/12/2015 09:13 AM
SynologyModuleConfig.jpg (11.1 KB) SynologyModuleConfig.jpg Benjamin Gilles, 06/12/2015 09:14 AM
SynologyFolderPerms.jpg (42.5 KB) SynologyFolderPerms.jpg Benjamin Gilles, 06/12/2015 09:15 AM
3092
3093
3094
3095

Associated revisions

Revision 22989b54 (diff)
Added by William Grzybowski over 5 years ago

Do not display certain values on datagrid depending on rsync mode choice Ticket: #9899 Merge-FN93: yes Merge-TN93: yes

Revision dde2b15a (diff)
Added by William Grzybowski over 5 years ago

Do not display certain values on datagrid depending on rsync mode choice Ticket: #9899 Merge-FN93: yes Merge-TN93: yes (cherry picked from commit 22989b549adeada17a3a3c258f9e4cdb6e265fd7)

Revision 00afd002 (diff)
Added by William Grzybowski over 5 years ago

Do not display certain values on datagrid depending on rsync mode choice Ticket: #9899 Merge-FN93: yes Merge-TN93: yes (cherry picked from commit 22989b549adeada17a3a3c258f9e4cdb6e265fd7)

Revision d22c1122 (diff)
Added by William Grzybowski over 5 years ago

Create a new session, set login and init groups when running rsync/cron Ticket: #9899 Merge-FN93: yes Merge-TN93: yes

Revision 234fa9fb (diff)
Added by William Grzybowski over 5 years ago

Create a new session, set login and init groups when running rsync/cron Ticket: #9899 Merge-FN93: yes Merge-TN93: yes (cherry picked from commit d22c112272ac30be5d990443e6c969bc90952d4d)

Revision 9e3f642b (diff)
Added by William Grzybowski over 5 years ago

Create a new session, set login and init groups when running rsync/cron Ticket: #9899 Merge-FN93: yes Merge-TN93: yes (cherry picked from commit d22c112272ac30be5d990443e6c969bc90952d4d)

Revision 5af5d984 (diff)
Added by William Grzybowski over 5 years ago

Set user context when switching to run task Ticket: #9899 Merge-FN93: yes Merge-TN93: yes

Revision 497f40c6 (diff)
Added by William Grzybowski over 5 years ago

Set user context when switching to run task Ticket: #9899 Merge-FN93: yes Merge-TN93: yes (cherry picked from commit 5af5d9840929fd128bcd94f60d42941280ccd753)

Revision dd7a6ff6 (diff)
Added by William Grzybowski over 5 years ago

Set user context when switching to run task Ticket: #9899 Merge-FN93: yes Merge-TN93: yes (cherry picked from commit 5af5d9840929fd128bcd94f60d42941280ccd753)

Revision 2b5e8584 (diff)
Added by William Grzybowski over 5 years ago

Fix typo for Cron Run Ticket: #9899 Merge-FN93: yes Merge-TN93: yes

Revision f768bdc8 (diff)
Added by William Grzybowski over 5 years ago

Fix typo for Cron Run Ticket: #9899 Merge-FN93: yes Merge-TN93: yes (cherry picked from commit 2b5e8584331214bc655a55f66c5869ed8ba4adbc)

Revision cf1896e8 (diff)
Added by William Grzybowski over 5 years ago

Fix typo for Cron Run Ticket: #9899 Merge-FN93: yes Merge-TN93: yes (cherry picked from commit 2b5e8584331214bc655a55f66c5869ed8ba4adbc)

Revision e773c08f (diff)
Added by William Grzybowski over 5 years ago

Fix typo for Cron Run, now in the right block :) Ticket: #9899 Merge-FN93: yes Merge-TN93: yes

Revision 8ed545e9 (diff)
Added by William Grzybowski over 5 years ago

Fix typo for Cron Run, now in the right block :) Ticket: #9899 Merge-FN93: yes Merge-TN93: yes (cherry picked from commit e773c08f91fa3612c90f7a6f73d6675463b58314)

Revision a1b0563f (diff)
Added by William Grzybowski over 5 years ago

Fix typo for Cron Run, now in the right block :) Ticket: #9899 Merge-FN93: yes Merge-TN93: yes (cherry picked from commit e773c08f91fa3612c90f7a6f73d6675463b58314)

History

#1 Updated by Jordan Hubbard over 5 years ago

  • Category set to 59
  • Assignee set to Suraj Ravichandran
  • Target version set to Unspecified

#2 Updated by Suraj Ravichandran over 5 years ago

  • Status changed from Unscreened to Screened

#3 Updated by Suraj Ravichandran over 5 years ago

  • Status changed from Screened to Unscreened
  • Assignee changed from Suraj Ravichandran to William Grzybowski

Over to william as he understands the os.fork() logic used in the "run now" version of the tasks (both rsync and cron)

#4 Updated by William Grzybowski over 5 years ago

  • Status changed from Unscreened to Screened

#5 Updated by Jordan Hubbard over 5 years ago

Any ideas about this one? There seem to be a lot of problems with the "rsync now" button being reported.

#6 Updated by William Grzybowski over 5 years ago

A lot of problems? I have not seem many reports other than this report. Matter in fact, I have only this one in my queue.

I cannot reproduce this issue either, do you care to paste details of how your rsync is configured?

#7 Updated by William Grzybowski over 5 years ago

PS: When I ask for details is everything you can provide, permissions and user on each side would be primary.

Thank you

#8 Updated by Benjamin Gilles over 5 years ago

3092
3093
3094
3095

Sure here are the screenshots of the configuration. I also just tested this to make sure it is still occurring and it is on the latest 9.3 stable. As stated in the word document the only shares that have a problem it seems are CIFS Shares that have had the Everyone group removed from access. This does not affect the sync though when the task is run via the schedule, only when using the 'Run Now' option. As the process has no permission errors when run via the scheduled time, only when using the Run Now option, I still think there is a difference between how the process is started and exists somewhere on the FreeNAS side not on the Synology.

User on Both Sides is user 'rsync'

Permissions for rsync user on FreeNAS side:

This is the rsync module that is being used from /etc/rsyncd.conf

This is the Directory Permissions on the Synology Side:

The rsync user on the synology side is a member of group 'users' and 'rsync' and has full read/write access to the rsync share.

#9 Updated by William Grzybowski over 5 years ago

Hi, can you try again with the new update that has been pushed yesterday?

#10 Updated by Benjamin Gilles over 5 years ago

I can confirm that I am no longer receiving the permission errors when using the 'Run Now' button, but I also did not have any modified data in these directories to sync since the last sync, but the permission errors would always occur regardless so I believe that issue is resolved. I will create some data to sync and test it further this evening when I get home.

Also the Port 22 is no longer displayed in the UI when using Module Mode.

I didn't see this specifically noted in the patch notes when I installed them. The patch version I am on is FreeNAS-9.3-STABLE-2015060162331.

Was there something included to specifically address this and I am curious what the fix was.

Thanks

#11 Updated by William Grzybowski over 5 years ago

  • Status changed from Screened to Resolved

Yes, this was addressed in this ticket as well but it didn't make to the changelog as I wanted to make sure the issue was resolved before closing the ticket.

Feel free to reopen this if you see the issues again.

Thanks.

#12 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Target version changed from Unspecified to N/A

#13 Updated by Dru Lavigne almost 3 years ago

  • File deleted (Rsync Issue.docx)

Also available in: Atom PDF